whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kiss Tibor <kiss.ti...@gmail.com>
Subject Re: CassandraServiceTest integration test does not complete
Date Thu, 04 Nov 2010 23:15:11 GMT
Thanks Tom!
Now the integration test is working.

On Thu, Nov 4, 2010 at 5:45 PM, Tom White <tom.e.white@gmail.com> wrote:

> What's the name and path of the CDH3b3 propeties file? Does it work if
> you remove that file?
>
> >
> > Still cannot run the integration test.
>
> I run
>
> mvn verify -Pintegration
> -DargLine="-Dwhirr.test.identity=$AWS_ACCESS_KEY_ID
> -Dwhirr.test.credential=$AWS_SECRET_ACCESS_KEY
> -Dconfig=.whirr-test.properties"
>
> and have a file called .whirr-test.properties which sets
> whirr.client-cidrs. This passes for me on trunk.
>
>
I also created a .whirr-test.properties where there I had to write the
following:
whirr.run-url-base=http://whirr.s3.amazonaws.com/0.3.0-incubating-SNAPSHOT/
then the integration test is getting done without errors.
(Still interesting why the run-url-base it defaults to me to the cloudera
version instead of apache version.)

Then now I can return to my original problem.

I run the integration test mentioned earlier not only from my laptop, but I
also run it from an ec2 instance and the resolve dns name on ec2
instance<https://groups.google.com/a/cloudera.org/group/cdh-user/browse_thread/thread/ae9bf2caf9b2a683>problem
has been reproduced with this too.
Now I will continue to fill the JIRA issue with some proposed patches, which
I know it works for me.

Cheers,
Tibor

Mime
View raw message