whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom White <tom.e.wh...@gmail.com>
Subject Re: CassandraServiceTest integration test does not complete
Date Thu, 04 Nov 2010 05:15:05 GMT
On Wed, Nov 3, 2010 at 12:54 PM, Kiss Tibor <kiss.tibor@gmail.com> wrote:
> Hi Tom,
>
> On Wed, Nov 3, 2010 at 8:27 PM, Tom White <tom.e.white@gmail.com> wrote:
>>
>> On Wed, Nov 3, 2010 at 12:17 PM, Kiss Tibor <kiss.tibor@gmail.com> wrote:
>>
>> > runurl
>> > http://whirr.s3.amazonaws.com/0.1.0%2B23/apache/cassandra/post-configure
>> > -c
>> > ec2 10.122.54.66
>> >
>> > So this is the problem! It is a different url.
>>
>> Yes, it looks like you are using the CDH3b3 configuration. Have you
>> inadvertently overridden run-url-base?
>>
>> Tom
>>
>
> Before checking out the svn trunk of apache whirr, I was playing with
> CDH3b3.
>
> I was never expecting to read my cluster specification from
> ~/hadoop.properties.

It does if you specify --config hadoop.properties. The rules for
looking for the file are listed here:
http://commons.apache.org/configuration/userguide/howto_filebased.html

> I thought the svn trunk of apache distribution does not
> sees anything from my CDH3b3 conf, because I did not specified by --config
> parameter.
> I'm a bit confused, where should I check this run-url-base because simply I
> couldn't find a place for it.

It would be set using the whirr.run-url-base property in the
properties file or --run-url-base on the command line.

Cheers,
Tom

>
> Thanks in advance..
> Tibor
>

Mime
View raw message