whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Baclace <paul.bacl...@gmail.com>
Subject Re: can't connect to EC2 Cassandra cluster from inside EC2?
Date Wed, 14 Sep 2011 22:16:48 GMT
Were there any features added to 0.6.0 to support opening a port to 
public?   Currently, I use ec2- commands (ec2-describe-group  and 
ec2-authorize, just like Tom White's old Hadoop ec2 bash scripts) to 
post-process after the whirr driver script.


Paul

On 20110913 10:05 , Andrei Savu wrote:
> Check the security group settings using the aws console. You probably
> need to add more rules to allow machines in different security groups
> to talk to each other. By default we only allow access from the local
> machine.
>
> -- Andrei Savu / andreisavu.ro
>
> On Tue, Sep 13, 2011 at 8:04 AM, Khanh Nguyen<nguyen.h.khanh@gmail.com>  wrote:
>> Hi,
>>
>> I set up a Cassandra cluster in EC2. I can connect and interact with
>> it from my desktop. However, I can't connect when I am logged in to
>> one of my EC2 instances. I tried both the public and private IP. I
>> tried editting 'Listening Address' and "rpc address to "" and 0.0.0.0,
>> stop and restart Cassandra. I'm using pycassa. Thanks.
>>
>> -k
>>


Mime
View raw message