whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Schäfer <syrious3...@yahoo.de>
Subject Re: hbase cluster setup works - ssh to machine doesnt
Date Mon, 31 Oct 2011 18:03:45 GMT
I will do so.... I think it will take 2 months to get it finished



________________________________
Von: Andrei Savu <savu.andrei@gmail.com>
An: user@whirr.apache.org
Gesendet: 15:22 Montag, 31.Oktober 2011 
Betreff: Re: hbase cluster setup works - ssh to machine doesnt


Thanks for sharing. I would love to see the test results! 

Let me know if you face any problems while testing. 



-- Andrei Savu / andreisavu.ro


On Mon, Oct 31, 2011 at 3:15 PM, Christian Schäfer <syrious3000@yahoo.de> wrote:

Hello Andrei,
>
>mainly I will use whirr to create comparable hbase and cassandra test clusters.
>
>On these I will perform some benchmarks to make a afterwards an comprehensible decision
for a kind of a often called "web of things" project 
>where a lot of rfid-scan-event need to be stored and processed to monitor logistics.
>
>Because there are also some good benchmark papers (like http://research.yahoo.com/files/ycsb.pdf)

>I will look closer to HBase and will compare performance of using hbase-raw-api with datanucleus-hbase-jpa
>
>If anybody knows further (not too old) benchmark papers concerning hbase and cassandra
they are welcome :-)
>
>regards
>Christian
>
>P.S. just a kind notice: it would be sufficient if you would let the "mail to" only on
user@whirr.apache.org as I'm get all mails twice because my mail address is additionally in
the "mail to"
>
>
>________________________________
>Von: Andrei Savu <savu.andrei@gmail.com>
>An: user@whirr.apache.org; Christian Schäfer <syrious3000@yahoo.de>
>Gesendet: 12:57 Montag, 31.Oktober 2011 
>
>Betreff: Re: hbase cluster setup works - ssh to machine doesnt
>
>
>
>Christian - 
>
>I'm glad it works for you! 
>
>
>Can you share more about how are you using or planning to use Apache Whirr? 
>
>
>Thanks,
>
>
>
>-- Andrei Savu
>
>
>On Mon, Oct 31, 2011 at 1:52 PM, Christian Schäfer <syrious3000@yahoo.de> wrote:
>
>tried b) and it works ...thanks for the help :)
>>
>>
>>
>>
>>________________________________
>>Von: Andrei Savu <savu.andrei@gmail.com>
>>An: user@whirr.apache.org; Christian Schäfer <syrious3000@yahoo.de>
>>Gesendet: 12:07 Montag, 31.Oktober 2011 
>>
>>Betreff: Re: hbase cluster setup works - ssh to machine doesnt
>>
>>
>>
>>Both approaches should have the same end result: a successful ssh login on the remote
machine.
>>
>>
>>whirr.cluster-user defaults to the local user running Whirr. 
>>
>>
>>On Mon, Oct 31, 2011 at 1:02 PM, Christian Schäfer <syrious3000@yahoo.de> wrote:
>>
>>So before I burn another $ for nothing....should I try
>>>
>>>
>>>a)  ssh-i ~/.ssh/id_rsa ec2-50-17-89-76.compute-1.amazonaws.com
>>>or did you mean
>>>
>>>b) define whirr.cluster-user  = myName
>>>and after cluster launch connect with:
>>>ssh-i ~/.ssh/id_rsa myName@ec2-50-17-89-76.compute-1.amazonaws.com
>>>
>>>
>>>?
>>>
>>>
>>>
>>>________________________________
>>>Von: Andrei Savu <savu.andrei@gmail.com>
>>>An: user@whirr.apache.org; Christian Schäfer <syrious3000@yahoo.de>
>>>Gesendet: 10:23 Montag, 31.Oktober 2011 
>>>
>>>Betreff: Re: hbase cluster setup works - ssh to machine doesnt
>>>
>>>
>>>
>>>It is just discard ubuntu@host. 
>>>
>>>
>>>whirr.cluster-user  = your local user
>>>
>>>
>>>
>>>-- Andrei Savu
>>>
>>>
>>>On Mon, Oct 31, 2011 at 11:19 AM, Christian Schäfer <syrious3000@yahoo.de>
wrote:
>>>
>>>As written in my inital mail I exactly do installl and login as in the whirr faq/tutorial
>>>>
>>>>e.g. 
>>>>
>>>>hbase-ec2.properties
>>>>
>>>>>whirr.private-key-file=${sys:user.home}/.ssh/id_rsa
>>>>>whirr.public-key-file=${sys:user.home}/.ssh/id_rsa.pub
>>>>
>>>>
>>>>>ssh -i ~/.ssh/id_rsa ubuntu@ec2-204-236-242-13.compute-1.amazonaws.com
>>>>
>>>>the jira is maybe helpful...but when I configure whirr with freshly generated
rsa key pair it should after install be possible to login with the same keys...but isnt :(
>>>>
>>>>
>>>>________________________________
>>>>Von: Andrei Savu <savu.andrei@gmail.com>
>>>>An: user@whirr.apache.org; Christian Schäfer <syrious3000@yahoo.de>
>>>>Gesendet: 8:49 Montag, 31.Oktober 2011 
>>>>Betreff: Re: hbase cluster setup works - ssh to machine doesnt
>>>>
>>>>
>>>>
>>>>From the FAQ: http://whirr.apache.org/faq.html
>>>>How do I log in to a node in the cluster?
>>>>On EC2, if you know the node's address you can do:
>>>>ssh -i ~/.ssh/id_rsa <whirr.cluster-user>@host
>>>>This assumes that you use the default private key; if this is not the case
then specify the one you used at cluster launch.
>>>>whirr.cluster-user defaults to the name of the local user running Whirr.
>>>>I have also created this new JIRA issue so that we can actually display the
SSH command in the console:
>>>>https://issues.apache.org/jira/browse/WHIRR-419
>>>>Cheers,
>>>>-- Andrei Savu / andreisavu.ro
>>>>
>>>>
>>>>
>>>>On Mon, Oct 31, 2011 at 1:22 AM, Christian Schäfer <syrious3000@yahoo.de>
wrote:
>>>>
>>>>
>>>>>
>>>>>Hi there,
>>>>>
>>>>>
>>>>>just trying to get my first hbase test cluster of 6 machines working using
whirr-0.6.0-incubating...
>>>>>
>>>>>
>>>>>
>>>>>before cluster launch  I generated public/private key 
>>>>>
>>>>>>ssh-keygen -t rsa -P '' -f ~/.ssh/id_rsa
>>>>>
>>>>>..and set  key files in hbase-ec2.properties as follows
>>>>>
>>>>>>whirr.private-key-file=${sys:user.home}/.ssh/id_rsa
>>>>>>whirr.public-key-file=${sys:user.home}/.ssh/id_rsa.pub
>>>>>
>>>>>
>>>>>After:
>>>>>>/whirr-0.6.0-incubating$ bin/whirr launch-cluster --config hbase-ec2.properties
(prop. copied from recipes to parent dir)
>>>>>
>>>>>..cluster setup finished without a problem..
>>>>>
>>>>>
>>>>>But when I try (<user>@<machine> is copied from the aws console
after choosing "connect" on an  actually running machine ):
>>>>>>ssh -i ~/.ssh/id_rsa ubuntu@ec2-204-236-242-13.compute-1.amazonaws.com
>>>>>
>>>>>...I get permission denied:
>>>>>
>>>>>>The authenticity of host 'ec2-204-236-242-13.compute-1.amazonaws.com
(204.236.242.13)' can't be established.
>>>>>>RSA key fingerprint is **********************
>>>>>>Are you sure you want to continue connecting (yes/no)? yes
>>>>>>Warning: Permanently added 'ec2-204-236-242-13.compute-1.amazonaws.com,204.236.242.13'
(RSA) to the list of known hosts.
>>>>>>Permission denied (publickey).
>>>>>
>>>>>
>>>>>Has anybody a clue why that
 happens?
>>>>>
>>>>>Another thing I dont understand is that whirr is creating a security group
(jcloud...) and when I choose "connect" in the aws console it proposes a jclouds...pem file 
that I dont own and dont know where to get it from
>>>>>
>>>>>
>>>>>
>>>>>regards
>>>>>Chris
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>>
>>>
>>>
>>>
>>
>>
>>
>
>
>
Mime
View raw message