whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim R. Wilson" <wilson.ji...@gmail.com>
Subject Re: HBase on EC2: Could not resolve the DNS name of ...
Date Tue, 04 Oct 2011 19:06:47 GMT
Well, it would seem that the shell doesn't respect the proxy setting in
hbase-site.xml, but that's just a guess.  If so, that's more an HBase
problem than a Whirr problem I'd think.

-- Jim

On Tue, Oct 4, 2011 at 3:04 PM, Karel Vervaeke <karel@outerthought.org>wrote:

> I believe a workaround is to add entries to /etc/hosts, mapping the
> internal hostname (domU-.....internal) to the public ip address of the
> nodes. Not really sure though...
>
> On Tue, Oct 4, 2011 at 3:49 PM, Andrei Savu <savu.andrei@gmail.com> wrote:
>
>> This is a known issue and we don't have a workaround.
>>
>> Would it be possible to use the rest interface from the local machine? How
>> are you planning to use HBase?
>>
>> As a side note you can start in the same security group an "empty" machine
>> using the noop role.
>>
>> -- Andrei Savu / andreisavu.ro
>>
>>
>> On Tue, Oct 4, 2011 at 4:43 PM, Jim R. Wilson <wilson.jim.r@gmail.com>wrote:
>>
>>> Hi all,
>>>
>>> First, let me thank you for adding 0.90.3 support to Whirr 0.6.0 - this
>>> is a big help!
>>>
>>> I'm trying to run a small demo cluster based on the 0.90.3-ec2 recipe.
>>>  The cluster seems to be working, because when I SSH into a node and use the
>>> hbase shell (/usr/local/hbase-0.90.3/bin/hbase shell), commands seem to work
>>> as expected.
>>>
>>> However, when I try to connect from my local host by using the generated
>>> hbase-site.xml over the proxy tunnel created by hbase-proxy.sh, I get this
>>> error message:
>>>
>>> hbase(main):001:0> status
>>> 11/10/04 09:37:12 ERROR hbase.HServerAddress: Could not resolve the DNS
>>> name of domU-<...>.compute-1.internal:60000
>>>
>>> ERROR: java.lang.IllegalArgumentException: Could not resolve the DNS name
>>> of domU-<...>.compute-1.internal:60000
>>>
>>> Am I doing something wrong?  Is this a known issue?  Thanks,
>>>
>>> -- Jim R Wilson (jimbojw)
>>>
>>
>>
>
>
> --
> Karel Vervaeke
> http://outerthought.org/
> Open Source Content Applications
> Makers of Kauri, Daisy CMS and Lily
>

Mime
View raw message