whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Periya.Data" <periya.d...@gmail.com>
Subject trouble reaching ec-2 instance
Date Wed, 07 Dec 2011 22:58:31 GMT
Hi All,
    I am seeing a problem which has been reported earlier a few times, but,
I do not know the solution yet. I am unable to run "hadoop fs -ls /"
successfully "most" of the time from my laptop.

Some specs:
-----------------------
- My laptop :
Ubuntu 11.10 Oneiric Ocelot
Hadoop-0.20.2-cdh3u2
Apache Whirr 0.5.0-cdh3u2

EC2 instance: Ubuntu 10.04 32-bit LTS

*On term-1, I ran the proxy:*
sri@PeriyaData:~$ . ~/.whirr/HadoopDemo/hadoop-proxy.sh
Running proxy to Hadoop cluster at
ec2-174-129-76-176.compute-1.amazonaws.com. Use Ctrl-c to quit.
Warning: Permanently added
'ec2-174-129-76-176.compute-1.amazonaws.com,174.129.76.176'
(RSA) to the list of known hosts.


*On term-2, I exported conf-dir and did "hadoop fs - ls /"*
sri@PeriyaData:~$ export HADOOP_CONF_DIR=~/.whirr/JTVHadoopDemo/
sri@PeriyaData:~$ hadoop fs -ls /
11/12/07 13:43:18 WARN conf.Configuration: DEPRECATED: hadoop-site.xml
found in the classpath. Usage of hadoop-site.xml is deprecated. Instead use
core-site.xml, mapred-site.xml and hdfs-site.xml to override properties of
core-default.xml, mapred-default.xml and hdfs-default.xml respectively
Bad connection to FS. command aborted. exception: Call to
ec2-174-129-76-176.compute-1.amazonaws.com/174.129.76.176:8020 failed on
local exception: java.io.EOFException
sri@PeriyaData:~$

I tried the suggestion given at:
http://mail-archives.apache.org/mod_mbox/incubator-whirr-user/201106.mbox/%3C3A20A174-8D8B-4F84-80AF-C81A01B3732A@mortardata.com%3E.
Still did not work (after replacing host with external IP address).
According to this user who got it working, he mentions that the version of
hadoop instances must match...

Occasionally, for a different AMI, I get the "INFO ipc.Client: Retrying
connect to server:" issue. This has been reported here:
http://mail-archives.apache.org/mod_mbox/incubator-whirr-user/201107.mbox/%3CCAGtpQ96617csFRPL2ikq8p_W=TtXiod1SpQBe8WPNa4e5nq95g@mail.gmail.com%3E

Attached: Namenode and Jobtracker logs.

The reason why initially mentioned "mostly" is because I was able to run
this command successfully one time, but, since I was switching AMIs, I do
not remember.

Also, along the same lines, I am unable to use proxy on Firefox..even after
I ran the hadoop-proxy.sh and loaded the PAC file. Unable to view the
"browse the filesystem" link from the dfshealth.jsp page. Not sure if this
problem is a related one.

Thanks,
PD.

Mime
View raw message