whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Evan Pollan <evan.pol...@gmail.com>
Subject Re: Trunk build -- maven dependency resolution issue with thrift?
Date Thu, 23 Feb 2012 12:22:22 GMT
Sure -- I'll grab some log file info and file a bug when I get into the office. 

On Feb 23, 2012, at 6:10 AM, Andrei Savu <savu.andrei@gmail.com> wrote:

> Great! Can you add an issue to the jclouds issue tracker explaining the blocking behaviour
you are 
> seeing? (I guess there is some sort of infinite loop we need to remove)
> 
> http://code.google.com/p/jclouds/issues/list
> 
> ps: I've also forwarded this message on the jclouds-dev@ email list
> 
> On Thu, Feb 23, 2012 at 12:02 PM, Evan Pollan <evan.pollan@gmail.com> wrote:
> The OpenJDK is working just fine. I'm still pretty consistently running into the same
problem I've had since 0.6.0 wherein whirr hangs indefinitely trying to create EC2 spot instances,
but I have tooling to detect that, kill whirr, and retry. 
> 
> We also used my trunk build to stand up an HBase cluster using OpenJDK, and that seems
to be running OK, as well. 
> 
> We're fine with our one-off trunk build until 0.7.1 is released. 
> 
> Thanks!
> 
> 
> On Feb 23, 2012, at 5:50 AM, Andrei Savu <savu.andrei@gmail.com> wrote:
> 
>> Evan sorry for the late reply. How are things going with the openjdk version? Still
having issues? 
>> 
>> I can create a SNAPSHOT build from the 0.7 branch for you. I hope to get an RC out
in the afternoon / tonight.&nbs p;
>> 
>> 
>> On Sun, Feb 19, 2012 at 10:27 PM, Evan Pollan <evan.pollan@gmail.com> wrote:
>> Hmmm.  I don't have a ton of maven experience.  What's your upstream repo?  I assume
by "empty repo" you mean your local .m2 directory was empty?
>> 
>> The bazaarvoice repo is proxying probably 20-30 big repos, and we have a pretty big
development group.  If you're able resolve both the old thrift artifact and the odd version
of osgi, your upstream repo must be something we need to add to our nexus server :)
>> 
>> Anyhow.  Trunk is built, and I'll give it a whirl tomorrow with the openjdk option
enabled.  Hopefully, it'll go smoothly.
>> 
>> Thanks for all the help, Andrei.
>>  
>> 
>> On Sun, Feb 19, 2012 at 4:12 PM, Andrei Savu <savu.andrei@gmail.com> wrote:
>> I have just tried to build with an empty maven repo and it works. No ideas why this
is happening for you. I suspect the proxy server your are using. Can you give it a try without
using the proxy?
>> 
>> On Sun, Feb 19, 2012 at 3:55 AM, Evan Pollan <evan.pollan@gmail.com> wrote:
>> I just pulled down the whirr trunk via svn, but I get build failures with the services/hbase
maven module.  Here's the error that occurs (building the "install" goal via the top-level
reactor pom):
>> 
>> [ERROR] Failed to execute goal on project whirr-hbase: Could not resolve dependencies
for project org.apache.whirr:whirr-hbase:bundle:0.8.0-SNAPSHOT: Could not find artifact org.apache.thrift:thrift:jar:0.2.0
in [my maven repo here].
>> 
>> Is there a specific repo that I need to proxy through my nexus server to resolve
the thrift artifact?  We're proxying the usual suspects, but none of them have a "thrift"
artifact.  Maven central has a "libthrift" artifact, but it has versions 0.6.1, 0.7.0, and
0.8.0 (latest).  I didn't see anything in the BUILD.txt or README.txt addressing this... 

>> 
>> thanks,
>> Evan
>> 
>> 
>> 
> 

Mime
View raw message