whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Evan Pollan <evan.pol...@gmail.com>
Subject Trunk build -- maven dependency resolution issue with thrift?
Date Sun, 19 Feb 2012 03:55:39 GMT
I just pulled down the whirr trunk via svn, but I get build failures with
the services/hbase maven module.  Here's the error that occurs (building
the "install" goal via the top-level reactor pom):

[ERROR] Failed to execute goal on project whirr-hbase: Could not resolve
> dependencies for project
> org.apache.whirr:whirr-hbase:bundle:0.8.0-SNAPSHOT: Could not find artifact
> org.apache.thrift:thrift:jar:0.2.0 in [my maven repo here].


Is there a specific repo that I need to proxy through my nexus server to
resolve the thrift artifact?  We're proxying the usual suspects, but none
of them have a "thrift" artifact.  Maven central has a "libthrift"
artifact, but it has versions 0.6.1, 0.7.0, and 0.8.0 (latest).  I didn't
see anything in the BUILD.txt or README.txt addressing this...

thanks,
Evan

Mime
View raw message