whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ashish <paliwalash...@gmail.com>
Subject Re: Whirr installation issue
Date Sun, 15 Apr 2012 05:20:56 GMT
Debashish,

Can you check in the logs that services got started. You can do this
scanning the whirr.log or by logging into the machines and verifying
it. If something is missing, you can check /tmp/log onto the ec2
machine, to get an insight into what went wrong.

I would do the following
1. Verify everything went fine in whirr.log
2. Log into the machine and check all services are running (using ps or jps)
3. If all is working fine, then you should get the UI.

If nothing works out, I would use a existing recipe from
whirr_install/recipes and try. This would work as it is battle tested.

You can also join #whirr on IRC, a lot of folks are hanging out there
and might help you in real time :)

HTH !
ashish

On Fri, Apr 13, 2012 at 2:43 AM, Deb Ghosh <dgcloudera@gmail.com> wrote:
> Hi ,
> The problem is I am in Ubuntu 11.10 as my os and after launching hadoop ec2
> cluster  and running the proxyset up.sh as shown below after ==== , I am
> trying to http in the firefox bowser for the nodes like name node with the
> http://ec2-23-20-228-116.compute-1.amazonaws.com:50070/ – web UI for HDFS
> name node(s ) but it does not connect
>
> But when i use hadoop single node cluster in hadoop yahoo in the same os and
> use the web ui loacal host it goes to to the webui in the firefox
> http://localhost:50070/ – web UI for HDFS name node(s)
>
> =============
>
> Completed launch of myhadoopcluster
> Web UI available at http://ec2-23-20-228-116.compute-1.amazonaws.com
> Wrote Hadoop site file /home/debashig/.whirr/myhadoopcluster/hadoop-site.xml
> Wrote Hadoop proxy script
> /home/debashig/.whirr/myhadoopcluster/hadoop-proxy.sh
> Started cluster of 2 instances
> HadoopCluster{instances=[Instance{roles=[jt, nn],
> publicAddress=ec2-23-20-228-116.compute-1.amazonaws.com/23.20.228.116,
> privateAddress=/10.64.74.23}, Instance{roles=[tt, dn],
> publicAddress=/50.17.54.86, privateAddress=/10.204.74.58}],
> configuration={fs.default.name=hdfs://ec2-23-20-228-116.compute-1.amazonaws.com:8020/,
> mapred.job.tracker=ec2-23-20-228-116.compute-1.amazonaws.com:8021,
> hadoop.job.ugi=root,root,
> hadoop.rpc.socket.factory.class.default=org.apache.hadoop.net.SocksSocketFactory,
> hadoop.socks.server=localhost:6666}}
> debashig@ubuntu:~/amazon/Ec2_basic_setup/cloudera/whirr-0.1.0+23$ sh
> ~/.whirr/myhadoopcluster/hadoop-proxy.sh
> Running proxy to Hadoop cluster at
> ec2-23-20-228-116.compute-1.amazonaws.com. Use Ctrl-c to quit.
> Warning: Permanently added
> 'ec2-23-20-228-116.compute-1.amazonaws.com,23.20.228.116' (RSA) to the list
> of known hosts.
> =====================================
>
> Please provide your toughts or solution if any.
>
> Thanks
> Debashis
>
>
> On Tue, Apr 10, 2012 at 8:19 PM, Ashish <paliwalashish@gmail.com> wrote:
>>
>> The way I do this is, pick up the Name Node and Job Tracker URLs from
>> the whirr logs or console and punch them in on browser without any
>> change, and it works.
>>
>> I hope this is what you are trying to achieve.
>>
>>
>> On Wed, Apr 11, 2012 at 8:35 AM, Deb Ghosh <dgcloudera@gmail.com> wrote:
>> >
>> > Hello ,
>> >
>> > Would appreciate a help on the following issue :-
>> >
>> > I was installing whirr on Amazon ec2 cluster  the launch of whirr using
>> > my
>> > ubuntu 11.10 was ok
>> >
>> > then we did the following to run the proxy server
>> >
>> > sh ~/.whirr/myhadoopcluster/hadoop-proxy.sh
>> >
>> >    Running proxy to Hadoop cluster at
>> >    ec2-72-44-45-199.compute-1.amazonaws.com.
>> >    Use Ctrl-c to quit.
>> >
>> >
>> > The hadoop-proxy.sh is used to access the web interface of Hadoop
>> > securely.
>> > When we run this it will tunnel through to the cluster and give us
>> > access in
>> > the web browser via a SOCKS proxy. For this we changed the internet
>> > option
>> > for proxy and after that when we tried to access following jsp page
>> >
>> > http://<hostname>:50070/dfshealth.jsp  this was not working
>> >
>> >
>> > (here the hostname was real DNS address on Amazon ec2).
>> >
>> > It is waiting for sometime and then failing to connect to amazon server.
>> >
>> >
>> > Please let me know - How I need to resolve this asap.
>> >
>> >
>> > Thanks in advance
>> > Debashis  ( mobile # 5103662639)
>> >
>> >
>> >
>>
>>
>>
>> --
>> thanks
>> ashish
>>
>> Blog: http://www.ashishpaliwal.com/blog
>> My Photo Galleries: http://www.pbase.com/ashishpaliwal
>
>



-- 
thanks
ashish

Blog: http://www.ashishpaliwal.com/blog
My Photo Galleries: http://www.pbase.com/ashishpaliwal

Mime
View raw message