whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edmar Ferreira <edmaroliveiraferre...@gmail.com>
Subject Re: RuntimeException: java.util.concurrent.ExecutionException:
Date Tue, 03 Apr 2012 17:44:42 GMT
The lines that are not commented:

whirr.cluster-name=hadoop

whirr.instance-templates=1 hadoop-namenode+hadoop-jobtracker, 5
hadoop-datanode+hadoop-tasktracker
whirr.instance-templates-max-percent-failures=100
hadoop-namenode+hadoop-jobtracker,90 hadoop-datanode+hadoop-tasktracker

whirr.provider=aws-ec2
whirr.identity=${env:AWS_ACCESS_KEY_ID}
whirr.credential=${env:AWS_SECRET_ACCESS_KEY}





On Tue, Apr 3, 2012 at 9:01 AM, Andrei Savu <savu.andrei@gmail.com> wrote:

> Can you share your recipe? I am now testing the first release candidate
> for 0.7.2 - maybe this is something we can fix easily.
>
> -- Andrei
>
>
> On Mon, Apr 2, 2012 at 10:10 PM, Edmar Ferreira <
> edmaroliveiraferreira@gmail.com> wrote:
>
>> Every time I'm launching a new cluster I get this error:
>>
>> Caused by: java.lang.RuntimeException:
>> java.util.concurrent.ExecutionException: java.lang.RuntimeException: error
>> amis: [us-east-1=[formParameters={Filter.1.Name=[virtualization-type],
>> Filter.1.Value.1=[hvm], Filter.2.Name=[architecture],
>> Filter.2.Value.1=[x86_64], Filter.3.Name=[owner-id],
>> Filter.3.Value.1=[137112412989], Filter.3.Value.2=[099720109477],
>> Filter.4.Name=[hypervisor], Filter.4.Value.1=[xen], Filter.5.Name=[state],
>> Filter.5.Value.1=[available], Filter.6.Name=[image-type],
>> Filter.6.Value.1=[machine], Filter.7.Name=[root-device-type],
>> Filter.7.Value.1=[ebs]}]]: {us-east-1=[formParameters={Filter.1.Name=[virtualization-type],
>> Filter.1.Value.1=[hvm], Filter.2.Name=[architecture],
>> Filter.2.Value.1=[x86_64], Filter.3.Name=[owner-id],
>> Filter.3.Value.1=[137112412989], Filter.3.Value.2=[099720109477],
>> Filter.4.Name=[hypervisor], Filter.4.Value.1=[xen], Filter.5.Name=[state],
>> Filter.5.Value.1=[available], Filter.6.Name=[image-type],
>> Filter.6.Value.1=[machine], Filter.7.Name=[root-device-type],
>> Filter.7.Value.1=[ebs]}]=org.jclouds.http.HttpResponseException:
>> ec2.us-east-1.amazonaws.com connecting to POST
>> https://ec2.us-east-1.amazonaws.com/ HTTP/1.1}
>>
>>
>> I'm using whirr 0.7.1
>>
>> Any ideas why this error is happening ?
>>
>>
>>
>> --
>> Edmar Ferreira
>> Co-Founder at Everwrite
>>
>>
>


-- 
Edmar Ferreira
Co-Founder at Everwrite

Mime
View raw message