whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrei Savu <savu.and...@gmail.com>
Subject Re: Problem with Whirr 0.7.1, Apache Hadoop 1.0.2, and HBase
Date Wed, 04 Jul 2012 16:43:02 GMT
On Wed, Jul 4, 2012 at 4:07 AM, David Champagne <davidchampagne204@gmail.com
> wrote:

> Successfully executed configure script: [output=This function does
> nothing. It just needs to exist so Statements.call("retry_helpers") doesn't
> call something which doesn't exist
> Copy hadoop jar to HBase error: did not find your Hadoop installation
> , error=/sbin/runuser: user hadoop does not exist
>

I guess it failed to install Hadoop or the path is wrong.

I think you should try HBase from CDH3u4 ( hbase-0.90.6+84.29) with a
recipe like this:

https://github.com/apache/whirr/blob/trunk/services/cdh/src/test/resources/whirr-hbase-cdh-test.properties

Change: whirr.env.repo=cdh3u4 and use either openjdk or oab installer.

I'm not sure if this is going to work. Often HBase fails to start because
HDFS is not yet available.

-- Andrei Savu / axemblr.com

Mime
View raw message