whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Wiley <kwi...@keithwiley.com>
Subject Default whirr uses invalid hadoop URL
Date Tue, 12 Feb 2013 18:56:48 GMT
The default cdh recipe seems to look for hadoop here:
http://apache.osuosl.org/hadoop/common/hadoop-0.20.205.0/hadoop-0.20.205.0.tar.gz
...which is dead.  I realize I can override with this:
http://apache.osuosl.org/hadoop/common/hadoop-0.20.205.0/hadoop-0.20.205.0.tar.gz
...or some equivalent, but which is the default invalid in the first place?

More seriously, I am uncertain of the interaction between an overridden URL and the following:
whirr.hadoop-install-function=install_cdh_hadoop
whirr.hadoop-configure-function=configure_cdh_hadoop

Do those options require very specific hadoop versions and therefore must I be careful about
which URL I manually specify?

Thanks.

________________________________________________________________________________
Keith Wiley     kwiley@keithwiley.com     keithwiley.com    music.keithwiley.com

"You can scratch an itch, but you can't itch a scratch. Furthermore, an itch can
itch but a scratch can't scratch. Finally, a scratch can itch, but an itch can't
scratch. All together this implies: He scratched the itch from the scratch that
itched but would never itch the scratch from the itch that scratched."
                                           --  Keith Wiley
________________________________________________________________________________


Mime
View raw message