whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Wiley <kwi...@keithwiley.com>
Subject Re: Whirr deployed hadoop cluster is very perplexing
Date Tue, 12 Feb 2013 06:42:00 GMT
Where does Whirr set the standard Hadoop configurations and why would this be the default (meaning,
I simply followed the common Whirr tutorials online verbatim so I got whatever the default
behavior is).

On Feb 11, 2013, at 21:50 , Paul Baclace wrote:

> Check your fs.default.name setting in core-site.xml, it is probably set to file:/// ;
the value of this property is prepended to a path that has no URI protocol when resolved by
"hadoop fs -ls ..." and job inputs/outputs.
> 
> This "feature" enables local mode (single process) and pseudo or full cluster modes to
work using the same absolute paths without protocol:// in test scripts. I think I used it
once in 6 years, but someone out there might rely on it.
> 
> The above means that when using a real cluster,
> 
>    hadoop fs -ls file:///
> 
> will indeed show the local root filesystem.
> 
> 
> Paul


________________________________________________________________________________
Keith Wiley     kwiley@keithwiley.com     keithwiley.com    music.keithwiley.com

"What I primarily learned in grad school is how much I *don't* know.
Consequently, I left grad school with a higher ignorance to knowledge ratio than
when I entered."
                                           --  Keith Wiley
________________________________________________________________________________


Mime
View raw message