whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Oczkowski <Michael.Oczkow...@seeq.com>
Subject RE: whirr version returns can't find main
Date Mon, 28 Apr 2014 17:39:49 GMT
Yes I stupidly downloaded the wrong file and using the binary file works fine.

However when I did build the source (mvn install), even though it passed all tests, running
bin/whirr version gave me
Whirr {$project.version}
not
Whirr 0.8.2
as it does for the binary version.  I tried with both OpenJDK and Oracle 6 & 7 on Ubuntu
12.04, 13.10, and 14.04.

From: Marco Didonna [mailto:m.didonna86@gmail.com]
Sent: Sunday, April 27, 2014 8:18 AM
To: user@whirr.apache.org
Subject: Re: whirr version returns can't find main



On Wed, Apr 23, 2014 at 6:14 PM, Michael Oczkowski <Michael.Oczkowski@seeq.com<mailto:Michael.Oczkowski@seeq.com>>
wrote:
I downloaded Whirr 0.8.2 (also 0.8.1) on my Ubuntu 14.04 machines running OpenJDK 6.  When
I run bin/whirr version, the result is:

ubuntu@ip:~/Programs/Whirr/whirr-0.8.2-src$<mailto:ubuntu@ip:~/Programs/Whirr/whirr-0.8.2-src$>
bin/whirr version
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/whirr/cli/Main
Caused by: java.lang.ClassNotFoundException: org.apache.whirr.cli.Main
        at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
Could not find the main class: org.apache.whirr.cli.Main. Program will exit.


You seem to have downloaded the source only version of whirr. Therefore you need to compile
it first in order to run the whirr command. If you want to save yourself the trouble just
download the binary version: it's a ~25MB archive (for example http://it.apache.contactlab.it/whirr/whirr-0.8.2/whirr-0.8.2.tar.gz)



One one of the machines I did mvn install in the Whirr 0.8.2 root directory where all tests
passed and it built.  Afterwards, when I run bin/whirr version there, the result is:
Apache Whirr ${project.version}
Jclouds 1.5.8

Any idea what’s happening?  Thanks!


I don't get it: on some machine you did execute the compile command, on others you forgot
to do so? :)


Mime
View raw message