whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Oczkowski <Michael.Oczkow...@seeq.com>
Subject whirr version returns can't find main
Date Wed, 23 Apr 2014 16:14:10 GMT
I downloaded Whirr 0.8.2 (also 0.8.1) on my Ubuntu 14.04 machines running OpenJDK 6.  When
I run bin/whirr version, the result is:

ubuntu@ip:~/Programs/Whirr/whirr-0.8.2-src$<mailto:ubuntu@ip:~/Programs/Whirr/whirr-0.8.2-src$>
bin/whirr version
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/whirr/cli/Main
Caused by: java.lang.ClassNotFoundException: org.apache.whirr.cli.Main
        at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
Could not find the main class: org.apache.whirr.cli.Main. Program will exit.

One one of the machines I did mvn install in the Whirr 0.8.2 root directory where all tests
passed and it built.  Afterwards, when I run bin/whirr version there, the result is:
Apache Whirr ${project.version}
Jclouds 1.5.8

Any idea what's happening?  Thanks!


Michael Oczkowski, Ph.D.
Big Data Architect & Chief Data Scientist
Seeq Corporation
206-801-9339 x704
[cid:F25521F6-6CD3-434A-B057-562FA55E4AB6]<http://www.seeq.com/>
Transforming industrial process data into actionable intelligence
Connect: LinkedIn<http://www.linkedin.com/company/3126445?trk=tyah> | Facebook<https://www.facebook.com/pages/Seeq-Corporation/424546840977984>
| Twitter<https://twitter.com/SeeqCorporation>


Mime
View raw message