wink-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luciano Resende <luckbr1...@gmail.com>
Subject Re: I don't manage to update my remote resource.
Date Tue, 25 Feb 2014 18:01:34 GMT
Take a look at a sample application at :
http://svn.apache.org/viewvc/wink/sandbox/lresende/sample-jaxrs-webapp/

You might be missing the application file where you register your resources
http://svn.apache.org/viewvc/wink/sandbox/lresende/sample-jaxrs-webapp/src/main/webapp/WEB-INF/application?view=markup


On Tue, Feb 25, 2014 at 3:41 AM, laurent bernabe
<laurent.bernabe@gmail.com>wrote:

> Hello everyone,
>
> As I am learning REST development in Java and with Apache Wink, I am
> implementing a very simple HelloNickName server/client.
>
> I am using Eclipse Kepler 4.3 and Tomcat 6 (under Ubuntu 64 bits 13.10).
> I managed to create a localhost server inside Tomcat 6 with Wink library.
> I've joined the web.xml, HelloApplication.java and HelloResource.java for
> the server side.
> HelloResource has a GET and a PUT method.
>
> But there is the problem I am facing :
> I've written a tiny client (HelloNicknameClient) class in javase 7 in
> order to test the GET/PUT methods.
> What I was expecting is that the final String (result2) give me "Hello
> Laurent !", but it is still "Hello World !" as result1 String.
>
> What's wrong with my understanding of RESTful applications ? Should I
> change a kind of configuration in my server side ? And if yes, which one ?
>
> Regards
>



-- 
Luciano Resende
http://people.apache.org/~lresende
http://twitter.com/lresende1975
http://lresende.blogspot.com/

Mime
View raw message