ws-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From veit...@apache.org
Subject svn commit: r1839028 - in /webservices/axiom/trunk: pom.xml systests/psychopath-tests/pom.xml
Date Sat, 25 Aug 2018 11:31:04 GMT
Author: veithen
Date: Sat Aug 25 11:31:04 2018
New Revision: 1839028

URL: http://svn.apache.org/viewvc?rev=1839028&view=rev
Log:
Upgrade maven-enforcer-plugin to avoid MENFORCER-274.

Modified:
    webservices/axiom/trunk/pom.xml
    webservices/axiom/trunk/systests/psychopath-tests/pom.xml

Modified: webservices/axiom/trunk/pom.xml
URL: http://svn.apache.org/viewvc/webservices/axiom/trunk/pom.xml?rev=1839028&r1=1839027&r2=1839028&view=diff
==============================================================================
--- webservices/axiom/trunk/pom.xml (original)
+++ webservices/axiom/trunk/pom.xml Sat Aug 25 11:31:04 2018
@@ -685,7 +685,7 @@
                 </plugin>
                 <plugin>
                     <artifactId>maven-enforcer-plugin</artifactId>
-                    <version>1.4.1</version>
+                    <version>3.0.0-M2</version>
                 </plugin>
                 <plugin>
                     <artifactId>maven-compiler-plugin</artifactId>
@@ -831,6 +831,12 @@
                         <requireNoRepositories>
                             <message>The POM must not include repository definitions
since non Apache repositories threaten the build stability.</message>
                             <banRepositories>true</banRepositories>
+                            <!-- We need the Eclipse P2 repository for one of the Eclipse
releases. If we select the
+                                 repository carefully, then it is reasonable to assume that
this doesn't threaten
+                                 the build stability. -->
+                            <allowedRepositories>
+                                <allowedRepository>kepler</allowedRepository>
+                            </allowedRepositories>
                             <banPluginRepositories>true</banPluginRepositories>
                             <!-- We still need to allow the Apache snapshot repository
-->
                             <allowSnapshotRepositories>true</allowSnapshotRepositories>

Modified: webservices/axiom/trunk/systests/psychopath-tests/pom.xml
URL: http://svn.apache.org/viewvc/webservices/axiom/trunk/systests/psychopath-tests/pom.xml?rev=1839028&r1=1839027&r2=1839028&view=diff
==============================================================================
--- webservices/axiom/trunk/systests/psychopath-tests/pom.xml (original)
+++ webservices/axiom/trunk/systests/psychopath-tests/pom.xml Sat Aug 25 11:31:04 2018
@@ -73,21 +73,6 @@
     </dependencies>
 
     <build>
-        <plugins>
-            <plugin>
-                <artifactId>maven-enforcer-plugin</artifactId>
-                <configuration>
-                    <rules>
-                        <requireNoRepositories>
-                            <!-- We need the Eclipse P2 repository for one of the Eclipse
releases. If we select the
-                                 repository carefully, then it is reasonable to assume that
this doesn't threaten
-                                 the build stability. -->
-                            <banRepositories>false</banRepositories>
-                        </requireNoRepositories>
-                    </rules>
-                </configuration>
-            </plugin>
-        </plugins>
         <extensions>
             <extension>
                 <groupId>com.github.veithen.cosmos</groupId>



Mime
View raw message