ws-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From VC Ramesh <>
Subject Re: jUDDI DataSource Connection Problem (Cannot create PoolableConnectionFactory)
Date Sat, 20 Dec 2003 20:44:47 GMT
Thanks to those that responded. The problem is solved ---- there was a password mismatch between
MySQL (what I had set up) and jUDDI. I changed the password in MySQL and it now works fine.
BTW, to the person that asked, Axis worked fine all along.

VC Ramesh <> wrote:
happyjuddi.jsp gives me the following error: (full text of the page enclosed at end of message)
jUDDI DataSource Check
+ Got a JNDI Context!+ Got a JDBC DataSource (dsname=java:comp/env/jdbc/juddiDB)- DB connection
was not aquired. (Cannot create PoolableConnectionFactory)- SELECT COUNT(*) FROM PUBLISHER
failed (null)I am using the latest versions of the respective software 

(Tomcat 5.0.16, jUDDI 0.8.0, MySQL 4.0.17, Java SDK j2sdk1.4.2.03,

JDBC driver mysql-connector-java-3.0.9-stable-bin.jar) on Windows 2000.

I have tried setting juddi.useConnectionPool to True but that

didn't resolve the issue. I have followed the instructions in 

a couple of archived messages I unearthed on this problem; but

nothing seems to work for me. Thanks for any suggestions/help.

-- Ramesh

------------ the happyjuddi.jsp output page -----

jUDDI Happiness
Happy jUDDI!

jUDDI Dependencies: Class Files & Libraries
Looking for: org.juddi.registry.Registry
+Found in: c:\jakarta-tomcat-5.0.16\webapps\juddi\WEB-INF\lib\juddi.jar
Looking for: javax.xml.soap.SOAPMessage
+Found in: c:\jakarta-tomcat-5.0.16\webapps\juddi\WEB-INF\lib\saaj.jar
Looking for: javax.xml.rpc.Service
+Found in: c:\jakarta-tomcat-5.0.16\webapps\juddi\WEB-INF\lib\jaxrpc.jar
Looking for: org.apache.axis.transport.http.AxisServlet
+Found in: c:\jakarta-tomcat-5.0.16\webapps\juddi\WEB-INF\lib\axis.jar
Looking for: org.apache.commons.discovery.Resource
+Found in: c:\jakarta-tomcat-5.0.16\webapps\juddi\WEB-INF\lib\commons-discovery.jar
Looking for: org.apache.commons.logging.Log
+Found in: c:\jakarta-tomcat-5.0.16\bin\commons-logging-api.jar
Looking for: org.apache.log4j.Layout
+Found in: c:\jakarta-tomcat-5.0.16\webapps\juddi\WEB-INF\lib\log4j-1.2.8.jar
Looking for:
+Found in: c:\jakarta-tomcat-5.0.16\webapps\juddi\WEB-INF\lib\wsdl4j.jar
Looking for: javax.xml.parsers.SAXParserFactory
+Found in an unknown location
Looking for: javax.activation.DataHandler
+Found in: c:\jakarta-tomcat-5.0.16\common\lib\activation.jar


jUDDI Dependencies: Resource & Properties Files
Looking for:
+Found in: c:\jakarta-tomcat-5.0.16\webapps\juddi\WEB-INF\classes\
Looking for:
+Found in: c:\jakarta-tomcat-5.0.16\webapps\juddi\WEB-INF\classes\


jUDDI DataSource Check
+ Got a JNDI Context!
+ Got a JDBC DataSource (dsname=java:comp/env/jdbc/juddiDB)
- DB connection was not aquired. (Cannot create PoolableConnectionFactory)


jUDDI Properties
juddi.adminURL: http://localhost:8080/juddi/admin
juddi.authFactory: org.juddi.auth.simple.SimpleAuthenticatorFactory
juddi.dataSource: java:comp/env/jdbc/juddiDB
juddi.dataStoreFactory: org.juddi.datastore.jdbc.JDBCDataStoreFactory
juddi.inquiryURL: http://localhost:8080/juddi/inquiry
juddi.jdbcDriver: com.mysql.jdbc.Driver
juddi.jdbcPassword: juddi
juddi.jdbcURL: jdbc:mysql://localhost/juddi
juddi.jdbcUser: juddi
juddi.maxMessageSize: 2097152
juddi.maxNameElementsAllowed: 5
juddi.maxNameLength: 255
juddi.operatorSiteURL: http://localhost:8080/juddi
juddi.publishURL: http://localhost:8080/juddi/publish
juddi.transportClass: org.juddi.transport.axis.AxisTransport
juddi.useConnectionPool: false
juddi.uuidgenFactory: org.juddi.uuidgen.jvm.JavaUUIDGenFactory


Platform: Apache Tomcat/5.0.16 

Do you Yahoo!?
New Yahoo! Photos - easier uploading and sharing

Do you Yahoo!?
New Yahoo! Photos - easier uploading and sharing
View raw message