ws-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Bosak (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (XMLSCHEMA-19) ValidationEventHandler is missing from the 2.x codebase
Date Sat, 04 Feb 2012 18:33:53 GMT

    [ https://issues.apache.org/jira/browse/XMLSCHEMA-19?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13200489#comment-13200489
] 

Martin Bosak commented on XMLSCHEMA-19:
---------------------------------------

Let me elaborate on the problem I am having.

We are currently changing the SOAP processing stack we use.  We currently use Spring Web Services
(v1.5.6) and are moving to Apache CXF.

Spring-WS uses XmlSchema 1.4.4 and CXF uses xmlschema-core 2.0.1.

I tried removing the 1.4.4 jar from the web app and used the 2.0.1 jar, I received a class
not found exception for ValidationEventHandler when a validation interceptor from Spring-WS
was loaded.

When I removed the 2.0.1 jar and used the 1.4.4, a CXF class couldn't find a class (I don't
remember which one; but it had QUALIFIED as part of the name).

Thus, I have a quandry and am only requesting that ValidationEventHandler class be added to
the 2.x codebase.  (At this point, I really don't care if it actually works).

I didn't think it would be a big problem because the code of ValidationEventHandler is essentially
empty:

package org.apache.ws.commons.schema;
 	
public class ValidationEventHandler {
 	
 	/**
 	* Creates new ValidationEventHandler
 	*/
 	public ValidationEventHandler() {
 	}
 	
}



                
> ValidationEventHandler is missing from the 2.x codebase
> -------------------------------------------------------
>
>                 Key: XMLSCHEMA-19
>                 URL: https://issues.apache.org/jira/browse/XMLSCHEMA-19
>             Project: XmlSchema
>          Issue Type: Bug
>    Affects Versions: XmlSchema 2.0.1
>            Reporter: Martin Bosak
>
> The xmlschema-core jar does not include ValidationEventHandler  that was in the 1.4.x
xmlschema file.
> This makes it impossible to upgrade to the new code.
> I don't know if this was intentional.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ws.apache.org
For additional commands, e-mail: dev-help@ws.apache.org


Mime
View raw message