ws-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colm O hEigeartaigh <cohei...@apache.org>
Subject Re: Dependency tree question
Date Thu, 12 Apr 2012 13:55:13 GMT
Are you getting the error in WSS4J itself or in your own code? Could
you paste the stacktrace?

Colm.

On Thu, Apr 12, 2012 at 2:39 PM, Stephanie Stroka
<stephanie.stroka@adnovum.ch> wrote:
> Hey!
>
> Thanks for your answer Colm!
> I'm using ant. I think that opensaml uses xmlsec 1.5.1 in my setup.
>
> I come to realize that maybe this mailinglist is not the one I should aim
> for since I do not have any particular problems with wss4j.
> I think the main problem is rather that opensaml does not register the id's
> for the XML Signatures correctly and so the verification of the signature
> fails because the element with a certain ID cannot be resolved by the new
> xmlsec lib.
>
> But maybe one of you experienced a similar problem before and has some idea
> about how I could register the id correctly.
>
> best wishes,
> Stephanie
>
>
>
> On 04/12/12 15:30, Colm O hEigeartaigh wrote:
>>
>> What are you using to build your project? WSS4J excludes the XML
>> Security dependency coming from opensaml by defining a dependency on
>> XML Security 1.5.1 which overrides the 1.4.4 version coming in via
>> Opensaml.
>>
>> http://svn.apache.org/viewvc/webservices/wss4j/trunk/pom.xml?view=co
>>
>> Colm.
>>
>>
>>
>> On Thu, Apr 12, 2012 at 9:56 AM, Stephanie Stroka
>> <stephanie.stroka@adnovum.ch>  wrote:
>>>
>>> Hello!
>>>
>>> I was upgrading a project from wss4j 1.5.3 to 1.6.5, but I seem to have
>>> severe problems with resolving the dependencies and I was wondering if
>>> you
>>> could help me.
>>>
>>>  From the dependency tree of the wss website I figures that I have to
>>> upgrade
>>> the xmlsec library (which was in version 1.4.4) to 1.5.1.
>>> The opensaml library was already in version 2.5.1.
>>>
>>> The problem is that opensaml 2.5.1 has a dependency on xmltooling 1.3.2,
>>> which has a dependency on xmlsec 1.4.4. Although it is compiling, I'm
>>> experiencing problems at runtime.
>>> Since I upgraded to xmlsec 1.5.1 some things in opensaml are failing
>>> (e.g.
>>> because of the change in IdResolver of xmlsec, but that's not the only
>>> problematic part.)
>>>
>>> Do you have any suggestions on how you solved the dependency conflicts or
>>> do
>>> those conflicts not appear in you projects?
>>> I'd be very grateful for any suggestions and hints :)
>>>
>>> Best wishes,
>>> Stephanie
>>>
>>>
>>> --
>>> AdNovum Informatik AG
>>> Stephanie Stroka
>>> Dipl. Informatik-Ing. FH
>>>
>>> Roentgenstrasse 22, CH-8005 Zurich
>>> mailto:stephanie.stroka@adnovum.ch
>>> phone: +41 44 272 6111, fax: +41 44 272 6312
>>>
>>> http://www.adnovum.ch  AdNovum Offices: Bern, Budapest, Singapore, Zurich
>>> (HQ)
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@ws.apache.org
>>> For additional commands, e-mail: dev-help@ws.apache.org
>>>
>>
>>
>>
>
> --
> AdNovum Informatik AG
> Stephanie Stroka
> Dipl. Informatik-Ing. FH
>
> Roentgenstrasse 22, CH-8005 Zurich
> mailto:stephanie.stroka@adnovum.ch
> phone: +41 44 272 6111, fax: +41 44 272 6312
>
> http://www.adnovum.ch  AdNovum Offices: Bern, Budapest, Singapore, Zurich
> (HQ)
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: dev-help@ws.apache.org
>



-- 
Colm O hEigeartaigh

Talend Community Coder
http://coders.talend.com

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ws.apache.org
For additional commands, e-mail: dev-help@ws.apache.org


Mime
View raw message