ws-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Skorsky (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AXIOM-371) Add the version for the Axiom api bundle export package
Date Wed, 04 Jul 2012 11:00:36 GMT

    [ https://issues.apache.org/jira/browse/AXIOM-371?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13406441#comment-13406441
] 

Martin Skorsky commented on AXIOM-371:
--------------------------------------

For OSGi bundles it's recommended to use Import-Package over Require-Bundle. If you import
the packages with a version range (because you need some fixes or features), you don't get
the bundle wired if it does not export packages with a version.

Thus, it's required to export packages with versions even if running multiple versions in
parallel is not supported (singleton:=true).
                
> Add the version for the Axiom api bundle export package
> -------------------------------------------------------
>
>                 Key: AXIOM-371
>                 URL: https://issues.apache.org/jira/browse/AXIOM-371
>             Project: Axiom
>          Issue Type: Improvement
>          Components: API
>            Reporter: Willem Jiang
>            Assignee: Andreas Veithen
>         Attachments: AXIOM-371.patch
>
>
> As the Axiom API bundle export package doesn't have version , it cause some trouble when
you deploy different version of Axiom API bundle into OSGi container at the same time.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ws.apache.org
For additional commands, e-mail: dev-help@ws.apache.org


Mime
View raw message