ws-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AXIOM-426) StAX dialect resolved as UnknownStAXDialect under JBoss AS 7.1
Date Mon, 07 Jan 2013 23:04:12 GMT

    [ https://issues.apache.org/jira/browse/AXIOM-426?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13546388#comment-13546388
] 

Hudson commented on AXIOM-426:
------------------------------

Integrated in ws-axiom-trunk #1344 (See [https://builds.apache.org/job/ws-axiom-trunk/1344/])
    Switched the build to Java 6 (required for the test case for AXIOM-426), while still enforcing
Java 5 compatibility using the Animal Sniffer plugin. (Revision 1430042)
AXIOM-426:
* Fixed StAX dialect detection on JBoss AS 7.1.
* Added an Arquillian based test case that validates this on JBoss AS 7.1.1. (Revision 1430009)

     Result = SUCCESS
veithen : 
Files : 
* /webservices/commons/trunk/modules/axiom/pom.xml

veithen : 
Files : 
* /webservices/commons/trunk/modules/axiom/modules/axiom-api/src/main/java/org/apache/axiom/om/util/StAXUtils.java
* /webservices/commons/trunk/modules/axiom/modules/axiom-api/src/main/java/org/apache/axiom/util/stax/dialect/JBossFactoryUnwrapper.java
* /webservices/commons/trunk/modules/axiom/modules/axiom-api/src/main/java/org/apache/axiom/util/stax/dialect/StAXDialectDetector.java
* /webservices/commons/trunk/modules/axiom/systests/jboss-tests
* /webservices/commons/trunk/modules/axiom/systests/jboss-tests/pom.xml
* /webservices/commons/trunk/modules/axiom/systests/jboss-tests/src
* /webservices/commons/trunk/modules/axiom/systests/jboss-tests/src/test
* /webservices/commons/trunk/modules/axiom/systests/jboss-tests/src/test/java
* /webservices/commons/trunk/modules/axiom/systests/jboss-tests/src/test/java/org
* /webservices/commons/trunk/modules/axiom/systests/jboss-tests/src/test/java/org/apache
* /webservices/commons/trunk/modules/axiom/systests/jboss-tests/src/test/java/org/apache/axiom
* /webservices/commons/trunk/modules/axiom/systests/jboss-tests/src/test/java/org/apache/axiom/systest
* /webservices/commons/trunk/modules/axiom/systests/jboss-tests/src/test/java/org/apache/axiom/systest/jboss
* /webservices/commons/trunk/modules/axiom/systests/jboss-tests/src/test/java/org/apache/axiom/systest/jboss/DialectTest.java
* /webservices/commons/trunk/modules/axiom/systests/jboss-tests/src/test/resources
* /webservices/commons/trunk/modules/axiom/systests/jboss-tests/src/test/resources/arquillian.xml
* /webservices/commons/trunk/modules/axiom/systests/pom.xml

                
> StAX dialect resolved as UnknownStAXDialect under JBoss AS 7.1
> --------------------------------------------------------------
>
>                 Key: AXIOM-426
>                 URL: https://issues.apache.org/jira/browse/AXIOM-426
>             Project: Axiom
>          Issue Type: Bug
>          Components: API
>    Affects Versions: 1.2.13
>         Environment: Win7 Pro64, JDK 1.6.0_30, JBoss AS 7.1.1
>            Reporter: Alexander Morozov
>            Assignee: Andreas Veithen
>             Fix For: 1.2.15
>
>
> StAXDialectDetector cannot determine StAX dialect under JBoss AS 7.1.1 and fallback to
UnknownStAXDialect dialect. I've used woodstox 4.1.1 (packaged in ear). I've debug StAXDialectDetector#getDialect
and see that implementationClass points to JBoss's special class, "__redirected.__XMLInputFactory",
rootUrl determined as "jar:file:/D:/jboss7/jboss-modules.jar!/".
> I couldn't find any workaround for the issue and have stuck. Can anybody suggest a workaround
?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ws.apache.org
For additional commands, e-mail: dev-help@ws.apache.org


Mime
View raw message