ws-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marc Giger (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WSS-459) RequiredParts + EncryptedParts policy validation not working
Date Fri, 12 Jul 2013 15:13:49 GMT

    [ https://issues.apache.org/jira/browse/WSS-459?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13707000#comment-13707000
] 

Marc Giger commented on WSS-459:
--------------------------------

A "pre-validation" already exists for the policy stuff, it is executed as soon as the first
body element occurs.
It is used to validate the policy as far as we can at this stage.
                
> RequiredParts + EncryptedParts policy validation not working
> ------------------------------------------------------------
>
>                 Key: WSS-459
>                 URL: https://issues.apache.org/jira/browse/WSS-459
>             Project: WSS4J
>          Issue Type: Bug
>            Reporter: Colm O hEigeartaigh
>            Assignee: Marc Giger
>             Fix For: 2.0
>
>
> RequiredParts policy validation is not working. A CXF negative test-case (StaxPartsTest)
has a policy which "requires" a header of name "ToTo", however the (streaming) service throws
no error.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ws.apache.org
For additional commands, e-mail: dev-help@ws.apache.org


Mime
View raw message