ws-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colm O hEigeartaigh (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WSS-429) Consider some @Deprecated classes in the old namespace
Date Fri, 08 Nov 2013 16:45:19 GMT

    [ https://issues.apache.org/jira/browse/WSS-429?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13817424#comment-13817424
] 

Colm O hEigeartaigh commented on WSS-429:
-----------------------------------------


I've decided to not add in classes in the old "org.apache.ws.security" namespace. However,
I've reverted some of the changes to WSPasswordCallback, so all new users should have to do
is change the package of WSPasswordCallback from "org.apache.ws.security" to "org.apache.wss4j.common.ext".

Colm.

> Consider some @Deprecated classes in the old namespace
> ------------------------------------------------------
>
>                 Key: WSS-429
>                 URL: https://issues.apache.org/jira/browse/WSS-429
>             Project: WSS4J
>          Issue Type: Task
>            Reporter: Colm O hEigeartaigh
>            Assignee: Colm O hEigeartaigh
>             Fix For: 2.0
>
>
> WSS4J 2.0 will have the base package name "org.apache.wss4j", whereas WSS4J 1.6.x will
have "org.apache.ws.security". 
> For certain classes it may make sense to have @Deprecated classes in the old namespace,
that extend the new classes. Possibly in a separate module? 
> In particular I'm thinking about WSPasswordCallback and the SAML bean stuff, as if we
don't do this all users will have to migrate their CallbackHandler implementations as well.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ws.apache.org
For additional commands, e-mail: dev-help@ws.apache.org


Mime
View raw message