ws-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ronny Fraunhofer (JIRA)" <j...@apache.org>
Subject [jira] [Created] (WSS-557) Using MTOM and WS-Security leads to "Attachment not found"
Date Thu, 01 Oct 2015 19:39:27 GMT
Ronny Fraunhofer created WSS-557:
------------------------------------

             Summary: Using MTOM and WS-Security leads to "Attachment not found"
                 Key: WSS-557
                 URL: https://issues.apache.org/jira/browse/WSS-557
             Project: WSS4J
          Issue Type: Bug
          Components: WSS4J Core
    Affects Versions: 2.1.3
         Environment: Apache CXF 3.1.2, WSS4J 2.1.3, Wildfly 10.0.0CR2
            Reporter: Ronny Fraunhofer
            Assignee: Colm O hEigeartaigh


If using MTOM with WS-Security enabled, ids for XOP attachments will be URL encoded containing
an UID and the namespace.
If namespace contains characters that needs to be escaped WSS4J cannot find the correct attachment
as content ID of attachment contains decoded namespace.
Example:
xopUri from soap body: cid:c6bc87d0-ba03-48b0-9141-396281c61989-3@urn%3Aa%3Ab%3Ac%3A1.0
content ID in attachment list: c6bc87d0-ba03-48b0-9141-396281c61989-3@urn:a:b:c:1.0

Solution: URL-decode the xopUri to find correct attachment in attachment list



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ws.apache.org
For additional commands, e-mail: dev-help@ws.apache.org


Mime
View raw message