ws-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colm O hEigeartaigh (Jira)" <j...@apache.org>
Subject [jira] [Commented] (WSS-683) WSS4J depends on Velocity 1.7 which contains a security vulnerability (CVE-2020-13936)
Date Mon, 22 Mar 2021 09:11:00 GMT

    [ https://issues.apache.org/jira/browse/WSS-683?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17306034#comment-17306034
] 

Colm O hEigeartaigh commented on WSS-683:
-----------------------------------------

Can you attach a sample gradle project that I can use to reproduce the error?

> WSS4J depends on Velocity 1.7 which contains a security vulnerability (CVE-2020-13936)
> --------------------------------------------------------------------------------------
>
>                 Key: WSS-683
>                 URL: https://issues.apache.org/jira/browse/WSS-683
>             Project: WSS4J
>          Issue Type: Bug
>          Components: WSS4J Core
>    Affects Versions: 2.3.1
>            Reporter: Nick Monkman
>            Assignee: Colm O hEigeartaigh
>            Priority: Major
>              Labels: security
>
> WSS4J has a transitive dependency on velocity 1.7 (via OpenSAML 3.x) which is subject
to a high security vulnerability ( [https://nvd.nist.gov/vuln/detail/CVE-2020-13936] )
> WSS4J should update its OpenSAML dependency to 4.x thereby allowing velocity-core-engine
to be updated to the patched version (2.3)



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ws.apache.org
For additional commands, e-mail: dev-help@ws.apache.org


Mime
View raw message