ws-ews-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Srinath Perera <hemap...@gmail.com>
Subject Re: Some newbie questions
Date Tue, 01 Feb 2005 14:10:02 GMT
On Fri, 28 Jan 2005 18:41:09 +0530, Shahi, Ashutosh
<Ashutosh.Shahi@ca.com> wrote:
>  
>  
> 
> Hi Srinath, 
> 
> I was looking at the EWS stuff for the last few days and have some comments
> and questions on it. Would be great to hear your comments on them. 
> 
>   
>  
> LocalHome  and Local are always added to ejb-jar.xml irrespective of whether
> local classes are defined or not, this causes deployment to fail when local
> ejb class is not used. I think some condition has been missed in
> org/apache/Geronimo/ews/ws4j2ee/tows/ejb/EJBDDWriter.java, line 80 in the
> "if" statement, though don't know what that condition is. 
> Think there is some newline issues to be taken care of around lines 70-74 in
> file org/apache/Geronimo/ews/ws4j2ee/tows/ejb/EJBDDWriter.java which causes
> "\n" to be printed in ejb-jar.xml file. A double quote has been missed on
> line 72 I think. Also why is the namespace
> "http://www.ibm.com/webservices/xsd/j2ee_web_services_1_1.xsd" at line 73
> not assigned to anything? 
> I was looking at why in webservices.xml file <display-name> always gets
> "French Zip" and found out that most of the implementation in
> org/apache/geronimo/ews/ws4j2ee/context/webservices/server/WSCFWebserviceDescription.java
> has been commented. Where should I look to see how the context values are
> populated? 
> 
>   

Shahi, 
I will fix the above issues 
> Questions: 
>  
> Is this EWS correctly working currently? I see that Geronimo needs a EWS
> implementation and maven downloads it during building. Is this EWS being
> used there? 

yap it is used in the Geronimo; but it generate the artifacts that are
bit specific for the Geronimo in the Geronimo case.
> Is the generated jar/war/ear getting deployed on JBoss? I was trying to do
> that and haven't been successful. Anything that I might be missing? 
few month ago I have it working on JBoss, it should be can you send
what is the error you got! will get back to you on this

Thanks
Srinath

>   
> 
> Thanks, 
> 
> 
> ASHUTOSH SHAHI 
> 
>

---------------------------------------------------------------------
To unsubscribe, e-mail: ews-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: ews-dev-help@ws.apache.org


Mime
View raw message