ws-muse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jose Antonio (JIRA)" <j...@apache.org>
Subject [jira] Created: (MUSE-229) SOAPAction mismatch invoking service
Date Wed, 25 Apr 2007 16:23:15 GMT
SOAPAction mismatch invoking service
------------------------------------

                 Key: MUSE-229
                 URL: https://issues.apache.org/jira/browse/MUSE-229
             Project: Muse
          Issue Type: Bug
         Environment: Ubuntu 6.10, JDK 1.4.2, Tomcat 5.0.23
            Reporter: Jose Antonio
         Assigned To: Dan Jemiolo


I'm trying to invoke an Axis2 service inside a Muse service. To do
this I'm using the Axis2 service stub I generated but when I send a
message I get the following:

POST /axis2/services/RegistrationService HTTP/1.1

SOAPAction: "http://docs.oasis-open.org/wscaf/2005/10/wscf/RegistrationServicePortType/addParticipantResponse"

User-Agent: Axis2

Host: 127.0.0.1:8081

Transfer-Encoding: chunked

Content-Type: text/xml; charset=UTF-8



545

<?xml version='1.0' encoding='UTF-8'?>
 <soapenv:Envelope xmlns:wsa="http://www.w3.org/2005/08/addressing"
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
    <soapenv:Header>
       <wsa:To>http://localhost:8081/axis2/services/RegistrationService&lt;/wsa:To>
       <wsa:ReplyTo>
          <wsa:Address>http://www.w3.org/2005/08/addressing/anonymous&lt;/wsa:Address>
       </wsa:ReplyTo>
       <wsa:MessageID>urn:uuid:63015A36B234BC96B8117708283322511</wsa:MessageID>
       <wsa:Action>http://docs.oasis-open.org/wscaf/2005/10/wscf/RegistrationServicePortType/addParticipant&lt;/wsa:Action>
    </soapenv:Header>
........................

As you can see, the SOAPAction and wsa Action elements are different
and I don't know why. Using this same Stub in a local program I get
the same text in both elements and the call succeed but using it in
Muse gets this 'Response' part added. 

Using this same stub in a plain Axis2 service I get the correct SOAPAction header so it only
happens when invoking my service from Muse.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: muse-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: muse-dev-help@ws.apache.org


Mime
View raw message