ws-muse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Chris.Twi...@swisscom.com>
Subject RE: Web Services server behind a NAT router
Date Thu, 10 Jul 2008 11:33:44 GMT
Hi Eitan,

yes there is a solution, but it requires some coding.  There are functions in AbstractEnvironment
:

 getDefaultURI() and setDefaultURI()

the getter is in turn called by

  getDeploymentEPR()

which you can override with any uri you want.

Of course this means you coding an extra environment.

cheers,
Chris

-----Original Message-----
From: Eitan Plotnik [mailto:eplotnik@cisco.com]
Sent: Thursday, July 10, 2008 1:29 PM
To: muse-dev@ws.apache.org
Subject: Web Services server behind a NAT router



When a web services server is located behind a NAT router, it returns a private (e.g. non-globally-routable)
IP address in the EndpointReference.
When the client tries to send a request to the received epr, it fails with destination unreachable.

Is there a solution in Apache Muse for such a set-up?
--
View this message in context: http://www.nabble.com/Web-Services-server-behind-a-NAT-router-tp18380838p18380838.html
Sent from the Muse - Dev mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: muse-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: muse-dev-help@ws.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: muse-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: muse-dev-help@ws.apache.org


Mime
View raw message