ws-savan-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leon S. Searl (JIRA)" <j...@apache.org>
Subject [jira] Commented: (SAVAN-1) Savan is not getting configured in axis2(1.2)
Date Tue, 12 Feb 2008 17:41:11 GMT

    [ https://issues.apache.org/jira/browse/SAVAN-1?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12568242#action_12568242
] 

Leon S. Searl commented on SAVAN-1:
-----------------------------------

I had a similar problem with axis2 1.3 and savan snapshot 20080104.

I my case I had placed the mar in the modules repository and the jar in the axis2 lib.
The mar and jar are identical except that the savan-config.xml is not in the jar.
The class org.apache.savan.module.SavanModule, when initializing the savan
mar was using the 'default' class loader instead of the module class loader
when trying to configure the module so it was not looking in the mar for the
savan-config.xml resource and thus it failed.

This issue was masked for me for a while because if you do the
'mvn pacakge' twice without a 'mvn clean' in between the 
savan-config.xml file WILL be included in the jar file. 

> Savan is not getting configured in axis2(1.2) 
> ----------------------------------------------
>
>                 Key: SAVAN-1
>                 URL: https://issues.apache.org/jira/browse/SAVAN-1
>             Project: Savan
>          Issue Type: Bug
>         Environment: Windows Professional
>            Reporter: smitha aldrin
>            Priority: Blocker
>
> When i am putting savan.mar in the modules directory and savan-config in the web-inf
i am getting the message as cannot find savan-configuration file.
> Also the samples provided in savan is not working as axis1.1.1 kernel.jar is missing
EndPointReferenceHelper

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message