ws-savan-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Demetris <demet...@ece.neu.edu>
Subject Axis2 and POJO from Axis1
Date Tue, 13 Apr 2010 20:55:28 GMT

Hi all,

I am testing legacy WS modules that were running well on Axis 1.4.
In essense with minimal changes I have been able to deploy these services
on Axis2 1.5 in Tomcat. I can retrieve their WSDL docs the same way I did
with Axis 1.4. However, I am noticing that simple clients that generated 
SOAP
messages to access the services do not work unmodified with the services 
deployed
in Axis2 - this is normal I assume? Or should Axis2 be able to handle 
this correctly?

I also noticed that the WSDL of the POJO services in Axis 1.4 has the 
following
namespace in the PortType - something that is non-existant in the WSDL when
the service is deployed in Axis2:

<wsdl:operation name="getBooks">
<wsdlsoap:operation soapAction=""/>
-
<wsdl:input name="getBooksRequest">
<wsdlsoap:body encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" 
namespace="http://myBooks2" use="encoded"/>
</wsdl:input>


Not usre if this is relevant but I have a feeling it is- if the result 
that simple clients cannot
be used for both Axis 1.4 and Axis2 on the same POJO service then that 
answer my
questions - but can someone with more knowledge of this verify it?

Thanks

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message