ws-soap-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damian Alonso <dami...@objectconsulting.com.au>
Subject Extra line appearing in Apache Response
Date Mon, 30 Sep 2002 02:38:18 GMT
I'm wondering if anyone has seen this problem before.

We currently have an Apache SOAP 2.2 Service running, which is returning a
http response that looks like this:

<SOAP-ENV:Envelope
  xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
   <SOAP-ENV:Body>
       <ns1:someResponse>
	...
       </ns1:someResponse>

   </SOAP-ENV:Body>
</SOAP-ENV:Envelope>

The problem we have found is that some clients (e.g SilkPerformer for .NET)
are having problems handling the extra carriage return between the
'response' closing tag and the 'body' closing tag.  On all the examples I
have looked at, there normally is no carriage return between the 'response'
closing tag and the 'body' closing tag.  

E.g
<SOAP-ENV:Envelope
  xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
   <SOAP-ENV:Body>
       <ns1:someResponse>
	...
       </ns1:someResponse>
   </SOAP-ENV:Body>
</SOAP-ENV:Envelope>

We have found that this extra carriage return is in all our Apache SOAP
responses (no matter what service we are offering).  My question's are:

- Is that allowed (i.e the extra carriage return) as part of the SOAP 1.1
specification??
- Is that a bug with Apache's way of encoding the response??
- Does anyone know why this extra carriage return is being inserted  (i.e
what part of the Apache SOAP code does this serialization of the resonse)??
- Is it a flaw in the client because it cannot handle the extra carriage
return???

Any information on this or similar problems would be greatly appreciated.

Thanks in advance,

Damian.





Mime
View raw message