ws-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yiannis Mavroukakis" <jan...@chaosaltar.org>
Subject Re: Debug?
Date Thu, 02 May 2002 09:16:05 GMT
Thank you Gilad, I managed to figure it out, but it wasn't exactly what I
was after.
I need to see the XML string that is sent over the wire exactly as it is
i.e.
    <xml-rpc>
        <struct>
            <data>
                someTextData
            </data>
        </struct>
    </xml-rpc>

What I get with debug set to true, is the elements that make up the
structure, but no values associated with them. Is there anyway that this can
be done?

Thank you very much,

Yiannis.
----- Original Message -----
From: <gilad.buzi@bcn.concatel.com>
To: <rpc-user@xml.apache.org>
Sent: Thursday, May 02, 2002 10:10 AM
Subject: Re: Debug?



yiannis,

yes, whenever you want (in your code,)  you can call the following static
method (see the Api docs for more information):

XmlRpc.setDebug(true);

/gilad


 Gilad Buzi
 R&D Engineer · CONCATEL


 gilad.buzi@bcn.concatel.com
 c/Sardenya, 229-237 Atic. 2a ·
 08013 Barcelona Spain
 tel. +34.93.244.88.77 · fax
 +34.93.244.88.78

          www.concatel.com







                    "Yiannis
                    Mavroukakis"         Para:   <rpc-user@xml.apache.org>
                    <jander@chaos        cc:
                    altar.org>           Asunto:      Debug?

                    01/05/2002
                    12:03
                    Por favor,
                    responda a
                    rpc-user






Hello everyone,

Is there a way to set a debug mode in both an XML-RPC Server and Client
objects? I'm obviously interested in the output from the client and the
server.

Thank you,

Yiannis.









Mime
View raw message