ws-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wade Chandler <hwadechandler-apa...@yahoo.com>
Subject Re: AIX 5.2 Java 1.3.1 and 1.4 SecureWebServer IOException
Date Wed, 28 Dec 2005 19:49:42 GMT
--- John Southerland <john@southerland-consulting.com>
wrote:

> All,
> 
> I have recently tried to move my xmlrpc server app
> to a new os, AIX 5.2
> running Java 1.3.1 and tried 1.4, every time I try
> to startup a
> SecureWebServer, that works fine in Solaris and
> Linux, I get an IOException
> from the constructor with the text:
> "com.sun.net.ssl.internal.ssl.Provider"
> 
> I realize this is most likely an IBM JRE issue, but
> the security properties
> look fine, and I am definitely not overriding the
> system wide configuration.
> 
> This is actually a simple configuration, and since
> it works well on other
> operating systems, I was wondering if anyone else
> has encountered errors
> like this, or has any ideas on how I should
> continue.  I'm now officially
> stumped.
> 
>  
> 
> Also,
> 
> To add some comedy to this https problem, my non
> secure "backup" non ssl
> webserver (also the builtin xmlrpc server) starts
> fine on the server but the
> client gets an IOException on connect with the text
> "Remote host closed
> connection during handshake", not much of a backup
> connectivity method is
> it?
> 
>  
> 
> So please help me if you can, am I crazy, or is IBM
> to blame?
> 
> Thanks in advance, John
> 
>  
> 
> John Buren Southerland
> 
> Southerland Consulting
> 
> 801.467.8090(office)
> 
> 214.734.8099(cell)
> 
> john@southerland-consulting.com
> 
>  
> 
> 

I'm pretty sure IBM 1.4 should have the SSL and
support https.  I know I had to do some stuff to get
1.3.1 working though.  I had to install the separate
packages using the AIX install tool.  I downloaded the
packages from IBMs java site....the SSL and HTTPs
stuff is separte.  I then had to load the SSL provider
by:
System.setProperty("java.protocol.handler.pkgs","com.sun.net.ssl.internal.www.protocol");
Security.addProvider(new
com.sun.net.ssl.internal.ssl.Provider());

This was for some Axis stuff I was doing.

You can do this with text files in the java
distribution, but I couldn't figure out what all I had
to edit to get this just right in the IBM 1.3.1 VM.

See:
For Sun SSL for 1.3.x:
http://java.sun.com/products/jsse/index-103.html

IBM Java Extensions (native libs have to be installed
and all the goodies for ssl to work
(Java131.ext.security):
http://www-128.ibm.com/developerworks/java/jdk/aix/service.html

1.4.2 should already have the SSL stuff in it by
default, but since your code or XML-RPC which ever is
trying to directly use the Sun packages you'll have to
also install the Sun SSL extensions from above
(possibly).  I had to do some stuff to get Axis
working right on AIX.  The main reason was the
examples and underlying code of this service I had to
create.  

Looking in the XML-RPC SunSSLTransportFactory.java
file which is the transport you will end up using
defaultly I see the provider lines I mention above. 
So, you don't have to add the lines I have provided
above.  Simply installing the IBM ssl extensions for
1.3.1 and adding the Sun SSL packages to your ext
directory of that JDK/JRE or adding the Sun SSL
packages to your ext directory for the 1.4.2/1 (which
ever) directory should get you going.  However, using
the CommonsXmlRpcTransport directly instead of using
the default call methods might be a better thing for
you to do (some additions to your code and maybe a
little refactoring)...I'm not sure if the HttpClient
will use it's own SSL provider or what...someone else
might be able to tell you more about this.

Hope it helps,

Wade

Mime
View raw message