ws-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Wall <d.w...@computer.org>
Subject Tomcat 8 with older SOAP: DeployedServices.ds file no longer found
Date Mon, 20 Apr 2015 23:49:13 GMT
We have an old Java webapp from 2006 that uses the original Apache SOAP 
2.3.1.  It runs fine, albeit with old components.

In our process to upgrade some components, we've managed to run the new 
Java code under Java 8 without any issues, as well as upgraded the 
database and Linux OS.   We even managed to upgrade from Tomcat 5.5 to 
Tomcat 7 without any issues.

But when we upgrade from Tomcat 7 to Tomcat 8, we get this error when a 
SOAP call is first sent over:

*SOAP Service Manager: Unable to read 'DeployedServices.ds': assuming 
fresh start*

If we run it under Tomcat 7, it works fine.  So something has changed 
for Tomcat 8's classloaders or the like that is precluding it from 
finding the DeployedServices.ds file located in the root of my webapp 
(like webapps/ROOT/DeployedServices.ds).  I tried putting it into 
WEB-INF and WEB-INF/classes and META-INF, but it's never found.  
Unfortunately, it's not clear where Tomcat 8 is even checking for the file.

As we have clients still using the old SOAP interface, is there a way to 
get SOAP 2.3.1 to find the DeployedServices.ds file under Tomcat 8?

Thanks,
David

Mime
View raw message