ws-wsif-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aleksander Slominski <as...@cs.indiana.edu>
Subject Re: WSIF 2.0 and WSDL4J 1.4
Date Tue, 16 Nov 2004 16:34:16 GMT
what is your JDK and in particular SAX version you use?

if you are using the latest version of AXIS and WSDL4J i would suggest 
to build it from CVS:
http://ws.apache.org/wsif/developers/cvs.html

thanks,

alek

Rhett.DeWall@sybase.com wrote:

>
>
>The following URL is where I got WSDL4J v.1.4.
>http://www-124.ibm.com/developerworks/projects/wsdl4j/
>
>I see that AXIS 1.2-beta3 uses WSDL4J 1.5, and when I try to compile
>against that I receive the following errors:
>
>(See attached file: build.txt)
>
>I am building the wsif-2.0 release source, and not source from nightly
>builds...
>
>
>
>
>
>
>                                                                           
>             Aleksander                                                    
>             Slominski                                                     
>             <aslom@cs.indiana                                          To 
>             .edu>                     wsif-user@ws.apache.org             
>                                                                        cc 
>             11/15/2004 06:57          wsif-dev@ws.apache.org              
>             PM                                                    Subject 
>                                       Re: WSIF 2.0 and WSDL4J 1.4         
>                                                                           
>             Please respond to                                             
>             wsif-user@ws.apac                                             
>                  he.org                                                   
>                                                                           
>                                                                           
>
>
>
>
>what version did you try? the version in CVS builds OK with
>wsdl4j-20030807.jar and axis-1_2RC1.jar - i am not sure when was WSDL4J
>1.4  released?
>
>thanks,
>
>alek
>
>Rhett.DeWall@sybase.com wrote:
>
>  
>
>>After moving to AXIS 1.1, which includes WSDL4J 1.4, WSIF will no longer
>>build due to the following errors.  Is a release of WSIF available that
>>takes this into account?
>>
>>   [javac]     79. public class AuthenticatingProxyWSDLLocatorImpl
>>implements j
>>avax.wsdl.xml.WSDLLocator {
>>   [javac]                      ^--------------------------------^
>>   [javac] *** Error: The abstract method "org.xml.sax.InputSource
>>getBaseInput
>>Source();", inherited from type "javax/wsdl/xml/WSDLLocator", is not
>>implemented
>>in the non-abstract class
>>"org/apache/wsif/wsdl/AuthenticatingProxyWSDLLocatorI
>>mpl".
>>
>>   [javac] Found 1 semantic error compiling
>>"T:/apps/psesp/src/org/apache/wsif/
>>wsdl/WSIFWSDLLocatorImpl.java":
>>
>>   [javac]     79. public class WSIFWSDLLocatorImpl implements
>>javax.wsdl.xml.W
>>SDLLocator {
>>   [javac]                      ^-----------------^
>>   [javac] *** Error: The abstract method "org.xml.sax.InputSource
>>getBaseInput
>>Source();", inherited from type "javax/wsdl/xml/WSDLLocator", is not
>>implemented
>>in the non-abstract class "org/apache/wsif/wsdl/WSIFWSDLLocatorImpl".
>>
>>WSDL4J 1.4
>>javax.wsdl.xml
>>Interface WSDLLocator
>>getBaseInputSource
>>public org.xml.sax.InputSource getBaseInputSource()
>>     Returns an InputSource "pointed at" the base document.
>>
>>
>>
>>    
>>
>
>
>--
>The best way to predict the future is to invent it - Alan Kay
>
>  
>


-- 
The best way to predict the future is to invent it - Alan Kay


Mime
View raw message