ws-wsif-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Isaac (JIRA)" <wsif-...@ws.apache.org>
Subject [jira] Created: (WSIF-87) Adding NULL to Vector returns NullPointerException and nothing descriptive
Date Thu, 17 Aug 2006 19:58:14 GMT
Adding NULL to Vector returns NullPointerException and nothing descriptive
--------------------------------------------------------------------------

                 Key: WSIF-87
                 URL: http://issues.apache.org/jira/browse/WSIF-87
             Project: Axis-WSIF
          Issue Type: Bug
          Components: Basic Architecture
    Affects Versions: unspecified
         Environment: WinXP
Axis 1.4 (?)
Apache 2.2
Eclipse 3.1.2
JDK 1.5.0_06-b05
wtp-all-in-one-sdk-R-1.0.2
WTK
            Reporter: Isaac


Here goes.
Make a Axis webservice.
Do:
Vector v = new Vector();
v.add(NULL);

Return:
<soapenv:Body>
<soapenv:Fault>
<faultcode>soapenv:Server.userException</faultcode>
<faultstring>java.lang.NullPointerException</faultstring>
<detail>
<ns1:hostname xmlns:ns1="http://xml.apache.org/axis/">_____</ns1:hostname>
</detail>
</soapenv:Fault>
</soapenv:Body>

Expected: Something that tells me it crashed because I added a NULL to a Vector

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: wsif-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: wsif-dev-help@ws.apache.org


Mime
View raw message