www-announce mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb AT ASF <s...@apache.org>
Subject [ANNOUNCEMENT] Apache Commons Validator 1.5.0 released!
Date Tue, 24 Nov 2015 11:59:21 GMT
The Apache Commons Team is pleased to announce the release of Apache
Commons Validator 1.5.0

Apache Commons Validator provides the building blocks for both client side
validation and server side data validation. It may be used standalone or
with a framework like Struts.

1.5.0 is fully binary compatible to the last release. No client code
changes are required to migrate from version 1.4.x to 1.5.0. The minimum
required JDK version for this release is 1.6.

However note that the Javascript code has been dropped, see
https://issues.apache.org/jira/browse/VALIDATOR-371

Source and binary distributions are available for download from the Apache
Commons download site:
  http://commons.apache.org/proper/commons-validator/download_validator.cgi

When downloading, please verify signatures using the KEYS file available at
the above location when downloading the release.

Alternatively the release can be pulled via maven:
<dependency>
  <groupId>commons-validator</groupId>
  <artifactId>commons-validator</artifactId>
  <version>1.5.0</version>
</dependency>

Full details of all the changes in 1.5.0 can be found in the changelog:
  http://commons.apache.org/proper/commons-validator/changes-report.html

For complete information on Commons Validator, including instructions on
how to submit bug reports, patches, or suggestions for improvement, see the
Apache Commons Validator website:

http://commons.apache.org/proper/commons-validator/

Mime
View raw message