www-announce mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lukasz Lenart <lukaszlen...@apache.org>
Subject [ANN] Apache Struts 2.3.29 General Availability with Security Fixes Release
Date Fri, 17 Jun 2016 12:29:59 GMT
The Apache Struts group is pleased to announce that Struts 2.3.29 is
available as a “General Availability” release. The GA designation is
our highest quality grade.

Apache Struts 2 is an elegant, extensible framework for creating
enterprise-ready Java web applications. The framework is designed to
streamline the full development cycle, from building, to deploying, to
maintaining applications over time.

This release addresses two potential security vulnerabilities:

- S2-035 Action name clean up is error prone
- S2-036 Forced double OGNL evaluation, when evaluated on raw user
input in tag attributes, may lead to remote code execution (similar to
S2-029)
- S2-037 Remote Code Execution can be performed when using REST Plugin.
- S2-038 It is possible to bypass token validation and perform a CSRF attack
- S2-039 Getter as action method leads to security bypass
- S2-040 Input validation bypass using existing default action method.
- S2-041 Possible DoS attack when using URLValidator

This release contains several minor improvements just to mention few of them:
- Json result type breaks
- MessageStorePreResultListener doesn’t store messages for 3rd-party
RedirectResult subclasses
- Multiple tiles.xml in web.xml
- New Tiles version can not find tiles*.xml files in sub-directories
- EmailValidator flags .cat emails as invalid
- Struts2 JSON Plugin: messages in fieldsErrors are serialized twice
since jdk1.7_80
- Tile definition Inheritance/overriding is broken in Struts2 tiles
plugin 2.3.28+
- <s:submit> generates a value attribute for type=image which violates W3C
- ClassCastException while generating report using Struts 2.3.28 and
jasperreports 4.5.1

More details in version notes
http://struts.apache.org/docs/version-notes-2329.html

All developers are strongly advised to perform this action.

The 2.3.x series of the Apache Struts framework has a minimum
requirement of the following specification versions: Servlet API 2.4,
JSP API 2.0, and Java 6.
Should any issues arise with your use of any version of the Struts
framework, please post your comments to the user list, and, if
appropriate, file a tracking ticket.

You can download this version from our download page.
http://struts.apache.org/download.html#struts-ga


Regards
-- 
Łukasz
+ 48 606 323 122 http://www.lenart.org.pl/

Mime
View raw message