www-announce mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anthony Baker <aba...@apache.org>
Subject [SECURITY] CVE-2017-15696 Apache Geode configuration request authorization vulnerability
Date Thu, 22 Feb 2018 21:46:43 GMT
CVE-2017-15696 Apache Geode configuration request authorization vulnerability

Severity:  Important

Vendor: The Apache Software Foundation

Versions Affected:  Apache Geode 1.0.0 through 1.3.0

Description:
The Geode configuration service does not properly authorize
configuration requests.  This allows an unprivileged user who gains
access to the Geode locator to extract configuration data and
previously deployed application code.

Mitigation:
Users of the affected versions should upgrade to Apache Geode 1.4.0 or later.

Credit:
This issue was reported responsibly to the Apache Geode Security Team
by Dan Smith from Pivotal.

References:
[1] https://issues.apache.org/jira/browse/GEODE-3962
[2] https://cwiki.apache.org/confluence/display/GEODE/Release+Notes#ReleaseNotes-SecurityVulnerabilities

Mime
View raw message