www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mike machado <reed...@innercite.com>
Subject config/694: NO CGI's work
Date Sat, 07 Jun 1997 23:50:01 GMT

>Number:         694
>Category:       config
>Synopsis:       NO CGI's work
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    apache (Apache HTTP Project)
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Sat Jun  7 16:50:00 1997
>Originator:     reeders@innercite.com
>Organization:
apache
>Release:        1.2
>Environment:
LINUX ... downloaded the pre-compiled on Redhat distrobution which is the
same version and everything i have.
>Description:
I go to exec any cgi (even he script test-cgi that came with it) and i get :

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your
request.

then i goto my error logs and this is what it says:

exec of /usr/local/etc/httpd/cgi-bin/test-cgi failed, errno is 2
[Sat Jun  7 16:46:31 1997] access to /usr/local/etc/httpd/cgi-bin/test-cgi failed for mikie.domain.com,
reason: Premature end of script headers


>How-To-Repeat:
since my server is on my intranet you COULD point your proxies to
HTTP PROXY 158.222.2.14 port 80
SOCKS HOST 158.222.2.14 port 1080

and then goto the following URL  http://192.168.0.2/cgi-bin/test-cgi or http://192.168.0.2/cgi-bin/force.cgi
>Fix:

>Audit-Trail:
>Unformatted:



Mime
View raw message