www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken Kempster <kemps...@ibm.net>
Subject RE: general/693
Date Tue, 17 Jun 1997 02:10:01 GMT
The following reply was made to PR general/693; it has been noted by GNATS.

From: Ken Kempster <kempster@ibm.net>
To: Dean Gaudet <dgaudet@arctic.org>
Subject: RE: general/693
Date: Mon, 16 Jun 1997 21:33:47 -0400 (EDT)

 
 This is with it added to the EXTRA_LFLAGS..
 I added it to the Configuration file then ran
 Configure and then make.
 
 I checked the Makefile after running the Configure utility
 and the -lbind was on the LFLAGS line.
 
 But I tried adding the -lbind to the EXTRA_LIBS line in the Configuration
 file and this changed my error message and output:
 
 
 ...
 mod_browser.o regex/libregex.a -lbind
 collect2: ld returned 2 exit status
 ld: Undefined symbol
    ___ansi_realloc
 *** Error code 1
 make: Fatal error: Command failed for target 'httpd'
 
 THis looks better but still not there yet.
 
 
 On 16-Jun-97 Dean Gaudet wrote:
 >On Sat, 14 Jun 1997, Ken Kempster wrote:
 >>  gcc  -lbind  -o httpd alloc.o http_main.o http_core.o http_config.o ...
 >
 >This looks to me like you added -lbind to EXTRA_CFLAGS rather than
 >EXTRA_LFLAGS.  Libraries are only used for resolving references in the
 >objects to their left on the command line ... so in this case -lbind
 >isn't used to resolve anything.  Try using EXTRA_LFLAGS and see what
 >happens.
 >
 >Dean
 >
 >
 
 -----------------------------------------
 Ken Kempster     Network Systems Engineer
 E-Mail: Ken Kempster <kempster@ibm.net>
 Date: 16-Jun-97
 Time: 21:33:49
 -----------------------------------------

Mime
View raw message