www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken Kempster <kemps...@ibm.net>
Subject RE: general/693
Date Wed, 18 Jun 1997 06:20:02 GMT
The following reply was made to PR general/693; it has been noted by GNATS.

From: Ken Kempster <kempster@ibm.net>
To: Dean Gaudet <dgaudet@arctic.org>, marc@apache.org
Subject: RE: general/693
Date: Tue, 17 Jun 1997 23:05:33 -0400 (EDT)

 
 I tried adding the -lc along with the -lbind but
 still NG.
 But I found some information related to the missing 
 symbol in the README file for bind 8.1 under src/port
 
 If you do an nm on the libport.a file there you will see that
 ansi_realloc is defined there.  Then I looked in the sunos subdirectory
 and found an object file that was built; ansi_realloc.o
 
 But how can I include it into the compilation of apache??
 
 I tried coping the ansi_realloc.o file to the src directory for apache
 and added ansi_realloc.o to the EXTRA_INCLUDES line in the Makefile but
 I get the following error message when tring to build...
 
 gcc: ansi_realloc.o: linker input file unused since linking not done
 
 should I be tring this or tring to add this object into my system
 archives using ar??  What about adding it to the bind library
 that I'm including in the EXTRA_LIBS line?   IF you think this is the
 right course of action,  how would I go about doing this with ar ??
 
 
 On 17-Jun-97 Dean Gaudet wrote:
 >Try -lbind -lc on EXTRA_LIBS ... yeah I was being silly earlier it was
 >supposed to be on EXTRA_LIBS anyhow. 
 >
 >Dean
 >
 >On Mon, 16 Jun 1997, Ken Kempster wrote:
 >
 >> This is with it added to the EXTRA_LFLAGS..
 >> I added it to the Configuration file then ran
 >> Configure and then make.
 >> 
 >> I checked the Makefile after running the Configure utility
 >> and the -lbind was on the LFLAGS line.
 >> 
 >> But I tried adding the -lbind to the EXTRA_LIBS line in the Configuration
 >> file and this changed my error message and output:
 >> 
 >> 
 >> ...
 >> mod_browser.o regex/libregex.a -lbind
 >> collect2: ld returned 2 exit status
 >> ld: Undefined symbol
 >>    ___ansi_realloc
 >> *** Error code 1
 >> make: Fatal error: Command failed for target 'httpd'
 >> 
 >> THis looks better but still not there yet.
 >> 
 >> 
 >> On 16-Jun-97 Dean Gaudet wrote:
 >> >On Sat, 14 Jun 1997, Ken Kempster wrote:
 >> >>  gcc  -lbind  -o httpd alloc.o http_main.o http_core.o http_config.o ...
 >> >
 >> >This looks to me like you added -lbind to EXTRA_CFLAGS rather than
 >> >EXTRA_LFLAGS.  Libraries are only used for resolving references in the
 >> >objects to their left on the command line ... so in this case -lbind
 >> >isn't used to resolve anything.  Try using EXTRA_LFLAGS and see what
 >> >happens.
 >> >
 >> >Dean
 >> >
 >> >
 >> 
 >> -----------------------------------------
 >> Ken Kempster     Network Systems Engineer
 >> E-Mail: Ken Kempster <kempster@ibm.net>
 >> Date: 16-Jun-97
 >> Time: 21:33:49
 >> -----------------------------------------
 >> 
 >
 >
 
 -----------------------------------------
 Ken Kempster     Network Systems Engineer
 E-Mail: Ken Kempster <kempster@ibm.net>
 Date: 17-Jun-97
 Time: 23:05:38
 -----------------------------------------

Mime
View raw message