www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Juergen Gerharz <gerh...@dialup.nacamar.de>
Subject mod_include/2042: buffering script output
Date Tue, 07 Apr 1998 10:38:26 GMT

>Number:         2042
>Category:       mod_include
>Synopsis:       buffering script output
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Tue Apr  7 03:40:01 PDT 1998
>Last-Modified:
>Originator:     gerharz@dialup.nacamar.de
>Organization:
apache
>Release:        1.3b5
>Environment:
Linux RedHat5
>Description:
In the FAQ:
Note that in version 1.3, all CGI scripts will be unbuffered so the only difference between
nph scripts and normal scripts is that nph scripts require the full HTTP headers to be sent.


But when i try this
index.shtml:
<html>
<head>
<title></title>
</head>
<body>
<pre>
<!--#exec cmd="cgi-bin/test.cgi" -->
</pre>
</body>
</html>

text.cgi:
#!/bin/sh
date
sleep 2
date
sleep 2
date
sleep 2
date
sleep 2     

The result is send to the browser when the whole script is ready
I thought every output is send  unbuffered ?

Thanks
>How-To-Repeat:

>Fix:

>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]




Mime
View raw message