www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Clarkson <...@mailnurinet.com>
Subject mod_proxy/2215: mod_proxy fails to load under Win95
Date Mon, 11 May 1998 21:44:53 GMT

>Number:         2215
>Category:       mod_proxy
>Synopsis:       mod_proxy fails to load under Win95
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Mon May 11 14:50:01 PDT 1998
>Last-Modified:
>Originator:     net@mailnurinet.com
>Organization:
apache
>Release:        1.3b6 Windows
>Environment:
Win95 - binary distribution
>Description:
apache tries to load mod_proxy and then fails.
>How-To-Repeat:
try loading mod_proxy on a Win95 machine
>Fix:
 I got this reply which seems to identify the problem, though I haven't tried recompiling
it yet:

Date: Tue, 05 May 1998 10:17:31 -0700
From: jnyland @t workfire.com
Organization: Workfire Technologies Corporation
To: net @t nurinet.sq.com
Subject: Apache 1.3b6 proxy on Win95

Mike Clarkson wrote:

> >In <3546345C.FD01B4F4@workfire.com> "Jennifer S. Nyland"  writes:
>
> >>BTW, I'm running Apache 1.3b6 as a proxy on a Win95 machine.  Looks
> >>good.
>
> Are you running the caching as well?
>

No.  Not yet.  I suspect it will be OK though.

> Did you have to make any changes to the source or Makefiles to get the

> mod_proxy module to compile and load?
>

As I stated in another posting,The gory details: I tried doing
LoadModule, and it fails, so I copied all the .c and .h files from the
ApacheModuleProxy project into the ApacheCore project.  Then I hand
edited the modules.c file and rebuilt ApacheCore. (This is all in the
instructions somewhere.) Then I just removed the comment from the
ProxyRequests On line in httpd.conf.  The only thing that isn't quite
working right yet is that I have to copy ApacheCore.dll into the ApacheD
directory where the Apache.exe resides.

It works great, although it does definitely add some delay between the
browser's request and the response (no more so than other proxies). I
have yet to try it with caching, but we have two Win95 machines here
that are running Apache as a proxy, and the two copies of the Apache
code were built on two different Win95 machines, so it's repeatable. I
hope this helps.

...

I didn't post it to the bug list because I thought they'd probably know all about this by
now, ie that it's not the proxy module that's broken.  It's just the packaging of the proxy
as a dll that doesn't work right now on Win 95.

An update.  One of my colleagues here has been running an 8M Apache 1.3b6 proxy cache on Win95.
 (You had asked if we had any luck running the cache portion of the code.)



>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]




Mime
View raw message