www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From r..@hyperreal.org
Subject Re: general/2235: Apache 1.2.6 loses POST data
Date Mon, 18 May 1998 11:57:28 GMT
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]


Synopsis: Apache 1.2.6 loses POST data

State-Changed-From-To: open-feedback
State-Changed-By: rse
State-Changed-When: Mon May 18 04:57:28 PDT 1998
State-Changed-Why:
I've checked this with 1.3b7-dev and have a few
comments:

1. I was unable to verify the error. I tested 50 POSTs
   with NS 4.0 and every one worked correctly

2. I'm sure your given test program never run this
   way for you, because 
   - under FreeBSD /usr/bin/perl is a Perl 4
     which doesn't support neither "use" nor
     "use strict", etc.
   - the usage of "read" is totally wrong: read
     returns the number of read characters and 
     not the buffer (the buffer is already given
     as an argument).

So, I conclude that the error you observe is
either because of a programming problem inside
your real program or caused by some other things
we cannot reproduce with the current amount of
information. At least with 1.3b7-dev and the
following two files one cannot reproduce the error:
<html>
<body>
Text:
<FORM ACTION="form.cgi" METHOD=POST>
<INPUT TYPE="text" NAME="text" SIZE=20>
</FORM>
</body>
</html>
#!/sw/bin/perl -w
use strict;
my $buffer = "";
my $l = $ENV{'CONTENT_LENGTH'} || 0;
my $n;
$n = read(STDIN, $buffer, $l);
print "Content-type: text/html\n\n";
if ($buffer)
{ print $buffer; }
else
{ print "No data!"; }

You either have to find the error in your real
program or determine some more information 
to be able to reproduce the error. Please
try 1.3b6 or a snapshot of 1.3b7-dev yourself.
Perhaps its only an error under Apache 1.2 which
was already solved (I found no entry in our changelog
but who knows exactly ;-)


Mime
View raw message