www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eugene Blanchard <blanc...@cadvision.com>
Subject Re: general/3618: can't use .htaccess authentication with ~user. .htaccess is totally ignored.
Date Tue, 05 Jan 1999 07:10:01 GMT
The following reply was made to PR general/3618; it has been noted by GNATS.

From: Eugene Blanchard <blanchas@cadvision.com>
To: marc@apache.org
Cc: apbugs@apache.org
Subject: Re: general/3618: can't use .htaccess authentication with
  ~user. .htaccess is totally ignored.
Date: Mon, 04 Jan 1999 23:00:04 -0700

 At 08:15 AM 1/4/99 -0000, you wrote:
 >[In order for any reply to be added to the PR database, ]
 >[you need to include <apbugs@Apache.Org> in the Cc line ]
 >[and leave the subject line UNCHANGED.  This is not done]
 >[automatically because of the potential for mail loops. ]
 >[If you do not include this Cc, your reply may be ig-   ]
 >[nored unless you are responding to an explicit request ]
 >[from a developer.                                      ]
 >[Reply only with text; DO NOT SEND ATTACHMENTS!         ]
 >Synopsis: can't use .htaccess authentication with ~user. .htaccess is
 totally ignored.
 >State-Changed-From-To: open-feedback
 >State-Changed-By: marc
 >State-Changed-When: Mon Jan  4 00:15:09 PST 1999
 >Well, what does the error log say?
 Everything normal - no errors reported
 >What does "echo ~user" from a shell say?  ie. are you sure
 >it is actually /home being used, and not just something that
 >is a symlink to /home or /home is a symlink to.
 "echo ~user" reports /home/~user
 >You have
 >to modify your settings for the directory listed in the passwd
 I tried ~user/path/passwdfile and it was ignored.
 >All that "deny from none" does is deny accesses from a host
 >called "none".
 Thanks - removed..
 >This is almost certainly a configuration error and is very
 >unlikely to be anything resembling a bug in Apache.
 I rechecked all permissions and found that I had .htaccess set to 711,
 changed to 755. I then noticed that I had an extra file called
 "access.conf%". It had the configuration that I used to check /home
 directory configuration (typo in file name?). I reconfigured access.conf
 for /home and everything worked fine.
 Yes it was a configuration error - PEBKAC (problem exists between keyboard
 and chair). Thanks for responding and making me double check everything
 again. :-)
 * Eugene Blanchard            * The more I work on NT and Novell,   *
 * blanchas@cadvision.com      *    the more I like Linux!           *
 * eugene.blanchard@sait.ab.ca *  Linux - already Unix               *
 * Voice: (403) 284-7079       *               (not a wannabe)       *

View raw message