www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Derek Andree <dxan...@uswest.com>
Subject Re: config/3906: Servers hang on either Keepalive or on Read (if keepalive is turned off)
Date Thu, 27 May 1999 17:40:02 GMT
The following reply was made to PR config/3906; it has been noted by GNATS.

From: Derek Andree <dxandr2@uswest.com>
To: dgaudet@Apache.Org
Cc: apbugs@Apache.Org
Subject: Re: config/3906: Servers hang on either Keepalive or on Read (if 
 keepalive is turned off)
Date: Thu, 27 May 1999 10:25:16 -0700

 > Does this happen for you without mod_perl?
 
 it only happens when it's on production.  I've noticed that i cannot get
 connections to hang if I try connecting from localhost, yet i _can_ get
 them to hang if I telnet host 80 from another machine and just leave the
 session up... the timeout value is ignored and the connection is left
 open indefinitely.
  
 > I can't reproduce it using apache-1.3.7-dev on solaris 2.6...
 > (no related changes since 1.3.6)
 
 the only way i have been able to reproduce it reliably is on our
 production machine :(  on our test machine (identical to production in
 every aspect including hardware) i have been able to get a hung
 connection (stuck in Read when keepalives are turned off) by doing a
 telnet from a different host to port 80 of the webserver.  This doesn't
 seem to be consistent... some connections hang and some do not. 
 
 our machines have the latest patches from sun installed.
 
 i received a patch from you which i will try now and let you know if it
 works or not...
 
 thanks for the help!
 
 
 -- 
 Derek Andree
 Mobile Village Development
 dxandr2@uswest.com
 
 Diplomacy is the art of saying "nice doggy" until you can find a rock.

Mime
View raw message