www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nadine carlton <nadine_carl...@hp.com>
Subject mod_jserv/6298: The apache servlets will not restart due to "can not open/create semaphore error"
Date Tue, 11 Jul 2000 23:30:51 GMT

>Number:         6298
>Category:       mod_jserv
>Synopsis:       The apache servlets will not restart due to "can not open/create semaphore
error"
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    jserv
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Tue Jul 11 16:40:00 PDT 2000
>Closed-Date:
>Last-Modified:
>Originator:     nadine_carlton@hp.com
>Release:        Jserv 1.1
>Organization:
apache
>Environment:
NT 4.0 service pack 5.  JDK 1.2.2, but I'm running the precompiled
software.  Let me know what properties might be useful.
>Description:
After rebooting my system without a
clean shutdown, I`m not able to restart the Apache servlets process.  The error
is:

C:\>"c:\Program Files\Apache Group\Apache\Apache.exe" -d "c:\Program Files\Apach
e Group\Apache" -s
[Thu Jul 06 14:52:47 2000] [warn] pid file c:/program files/apache group/apache/
logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Thu Jul 06 14:52:47 2000] [crit] Apache JServ encountered a fatal error; check
your ApJServLogFile for details if none are present in this file.  Exiting.

The mod_jserv.log file contains:
[06/07/2000 21:50:54:687] (INFO) wrapper: Shutdown done (PID=105)
[06/07/2000 21:50:54:750] (INFO) Apache Module was cleaned-up
[06/07/2000 21:50:54:984] (INFO) wrapper: Java Virtual Machine started (PID=180)
[06/07/2000 21:50:54:984] (INFO) wrapper: controller started (PID=105)
[06/07/2000 21:52:47:781] (INFO) wrapper: can not open/create semaphore
[06/07/2000 21:52:47:781] (ERROR) an error returned initializing protocol "wrapper"
[06/07/2000 21:52:47:781] (ERROR) in init all protocols "wrapper" returned an error
[06/07/2000 21:52:47:781] (EMERGENCY) Error initializing protocols

If there is a semaphore out there on NT,
I can`t find it.  The apache source calls
CreateSemaphore with a name "jserv-wrapper-semaphore", but this file doesn`t exist.  I`ve
checked the apache web site FAQ and bug database also and couldn`t find anything.  NT help
doesn`t talk about semaphores.  I'm not using any
lockfile option either.

How do I fix this "can not open/create semaphore" error on NT?
>How-To-Repeat:
I don't know.  It wasn't a clean shutdown and I'm running HP espeak,
but the environment was ok before the restart.
>Fix:
No.
>Release-Note:
>Audit-Trail:
>Unformatted:
 [In order for any reply to be added to the PR database, you need]
 [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 [subject line starts with the report component and number, with ]
 [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 ["Re: general/1098:").  If the subject doesn't match this       ]
 [pattern, your message will be misfiled and ignored.  The       ]
 ["apbugs" address is not added to the Cc line of messages from  ]
 [the database automatically because of the potential for mail   ]
 [loops.  If you do not include this Cc, your reply may be ig-   ]
 [nored unless you are responding to an explicit request from a  ]
 [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 
 


Mime
View raw message