www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Clayton Vernon" <cver...@enron.com>
Subject Re: config/7553: configure generates an error
Date Tue, 17 Apr 2001 15:01:28 GMT
Sirs:

Thank you for your reply.

I decided to completely reinstall my OS and compilers and it now works fine.
It compiles beautifully, including the shared memory support

Here's what I now think: I had copied the /usr/ccs/bin/sparcv9 binaries (esp
'ld') up one level in the tree before. I wonder if this 'ld' works properly
with your software?

While the experts are here,

I am now having another difficulty, though. mod_jk.so doesn't build properly
for Apache 2.0. There are 4 error messages generated, 3 warnings related to
pointer casting and 1 fatal error related to the number of arguments to
ap_get_remote_host, which now has an extra (return) argument in the httpd
core source code related to whether or not the return string was an IP
address.

I get the errors either using a properly edited build-unix.sh or the
Makefile version. It is the proper source code (there is a difference in one
of the modules), the new 2.0 apxs script, and it build perfectly when I
switch over from the 2.0 to the 1.3 directory and build it (I have separate
apache and apache2 directory trees under /usr/local).

I've tried editing the call of the function itself, but I can't get it to
link properly. Has anyone gotten mod_jk to compile for Apache 2.0?

Thank you,

Clayton Vernon
Director, Models and Forecasts
Enron Corporation

PS I would like to help you, if I can. I am doing this on my new Sun 280R
server. If you would like for me to benchmark your 2.0 in some way on their
new 64-bit processors I would be happy to do so for you.

----- Original Message -----
From: <trawick@apache.org>
To: <apache-bugdb@apache.org>; <cvernon@enron.com>; <trawick@apache.org>
Sent: Tuesday, April 17, 2001 9:27 AM
Subject: Re: config/7553: configure generates an error


> [In order for any reply to be added to the PR database, you need]
> [to include <apbugs@Apache.Org> in the Cc line and make sure the]
> [subject line starts with the report component and number, with ]
> [or without any 'Re:' prefixes (such as "general/1098:" or      ]
> ["Re: general/1098:").  If the subject doesn't match this       ]
> [pattern, your message will be misfiled and ignored.  The       ]
> ["apbugs" address is not added to the Cc line of messages from  ]
> [the database automatically because of the potential for mail   ]
> [loops.  If you do not include this Cc, your reply may be ig-   ]
> [nored unless you are responding to an explicit request from a  ]
> [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
>
>
> Synopsis: configure generates an error
>
> State-Changed-From-To: open-feedback
> State-Changed-By: trawick
> State-Changed-When: Tue Apr 17 07:27:36 PDT 2001
> State-Changed-Why:
> Can you please include the complete output from configure?  I am
> able to successfully configure apache 2.0 on Solaris 8 + gcc.
> Hopefully a comparison of your configure output and mine will
> point to an earlier problem.  Also, include the contents of
> config.log.  This too has debugging information.
>
> Thanks!
>


Mime
View raw message